Excel Formulas and Functions

Formulas

- Relative cell references
- Absolute cell references
- Mixed cell references
- Naming a cell or range
- Naming constants
- Dates and times
- Natural-language formulas

Functions

- Now Function
- Date Function
- Date calculations
- Conditional Functions
- PMT Function
- Lookup Tables

Using Multiple Sheets and Workbooks

- Refer to cells in other worksheets and workbooks
- 3D formulas

Audit a Worksheet

- Trace precedents
- Trace dependents
- Trace Errors

Data Validation
Formulas

Relative Cell References
Calling cells by just their column and row labels (such as "A1") is called relative referencing. When a formula contains relative referencing and it is copied from one cell to another, Excel does not create an exact copy of the formula. It will change cell addresses relative to the row and column they are moved to. For example, if a simple addition formula in cell C1 =A1+B1 is copied to cell C2, the formula would change to =A2+B2 to reflect the new row.

Absolute Cell References
There are occasions when copying cell references that you don’t want the cell references to be adjusted automatically. To prevent this change, cells must be called by absolute referencing. This is accomplished by placing dollar signs ($) within the cell addresses in the formula. Continuing the previous example, the formula in cell C1 would read =$A$1+$B$1 if the value of cell C2 should be the sum of cells A1 and B1. Both the column and row of both cells are absolute and will not change when copied.

Mixed Cell References
Mixed cell referencing is when only part of the cell reference – the column letter or row number – is absolute, as in $A1 or A$1.

<table>
<thead>
<tr>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>January Visits</td>
<td>February Visits</td>
<td>% of Visits</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>CYP</td>
<td>3</td>
<td>2</td>
</tr>
<tr>
<td>7</td>
<td>EVC</td>
<td>5</td>
<td>8</td>
</tr>
<tr>
<td>8</td>
<td>NRG</td>
<td>16</td>
<td>23</td>
</tr>
<tr>
<td>9</td>
<td>Totals</td>
<td>=SUM(C6:C9)</td>
<td>=SUM(D6:D9)</td>
</tr>
</tbody>
</table>

When the formula in E6 gets copied to cell E7, it becomes =C7/C$9. The first cell reference (C6) is relative, so it is adjusted one row down. In the second cell reference (C$9), the row number is not adjusted because it is absolute.

Naming a Cell or Range
If you find yourself working within a large worksheet and you continue to return to the same cell or area within the worksheet, you may want to name the cell or range of cells. Once a cell or range is named, you can do the following:

- Jump to that cell or range by selecting its name from the Name box.
- Use the name as a cell or range reference in a formula or function.
- Choose the cell or range name from the Name box in order to select it within the worksheet.

There are several rules to keep in mind when naming a cell or range:

- You can use letters, numbers, and periods in a name, but no spaces.
- Instead of a space, use an underscore, as in fall_grades.
- The first character in the name must be a letter or an underscore character.
- You can’t name a cell anything that looks like a cell address, such as Q2 or FY2005.
- Names are not case-sensitive, so the name Grades, grades and GRADES are treated the same.
- Names are unique to the workbook to which they apply. You can reuse names in another workbook, but not in another sheet in the same workbook.
To name a cell or range:
1. Select the cell or range you want to name.
2. Click the **Name** box on the Formula Bar and type the name you want to use and press **Enter**.

To select a named cell or range:
1. Click the arrow on the **Name** box on the Formula bar.
2. Select a name from the drop-down list.

**Naming Constants**
Excel can give names to any constants. A constant in this context is a numeric value that does not change. If you set up a spreadsheet that constantly refers to a specific sales tax rate eg; 36%. You could type the rate (36% or 0.36) in all cells that need to use this value or you could give this value a name eg; SalesTax. For example, instead of typing \( =D8 \times 0.36 \) to calculate the sales tax, you could type \( =D8 \times \text{SalesTax} \). This can save a lot of time and is much easier than trying to locate all cells that use just the number.

To name a constant:
1. **Select Insert > Name > Define**, or press **Ctrl + F3**.

   The **Define Name** dialog box opens.

   2. Type the name you want to use in the **Names in workbook** box.
   3. In the **Refers to** box, type the value you wish to associate with the name. (In the above example, you would type .36)
   4. Click **Add** then click **Ok**.

**Dates and Times**
Excel uses the 1900 date system. The 1900 date system starts from 1 January 1900 and has a numeric value of 1. For example, if you type the date 4-Feb-1972 in any cell and selected General number format, it will display the value 26331. This simply means that 4-Feb-1972 is exactly 26331 days from 1-Jan-1900. By using this method Excel can perform calculations on dates.

So, Excel uses serial numbers to store dates and also uses a similar system to store times. Things to know when using time in Excel are:

- **Use Ctrl + ;** (semicolon) to enter the current date in a cell and **Ctrl + :** (colon) to enter the current time.
- Excel stores times as a portion on one, with one being equal to 24 hours.
- 12 hours is equal to 0.5 and six hours equal to 0.25.
- You can see the decimal fraction of a time by typing any time in any cell and format it as general. If you combine the date and time, 2-Feb-1972 12:00, format it as general, Excel will display 26331.5.

A common problem when working with times is the need to use hours greater than 24. In the example below, cells B2:B6 have the hours 8:00, 8:00, 10:00, 7:00, 7:30 respectively. These hours represent the hours worked in one week for an employee. We need to know the total hours worked for that week, so in cell B7 we put: =SUM(B2:B6). The result we end up with is 16:30. When you use a formula that references other cells, the result cell will automatically take on the format of the cell(s) it is referencing. Excel sees that there are times in cells B2:B7 and so assumes you want the same in your result or total cell and so formats it as h:mm.

You can force Excel to use the time format of "37:30:55" or a Custom format of "[h]:mm" to get the expected result of 40:30:00

**Natural-Language Formulas**

With natural-language formulas, you can enter a formula using the column and row labels in your worksheet. For example, in the following worksheet, the formula =SUM(B2:E2) can be written =SUM(HBC). This would give the total of the cells in the HBC row.

Excel does not normally look for natural-language formulas. You must turn that option on before you can use them.
To turn on natural-language formulas:
1. Click Tools > Options.
2. Click the Calculation tab.
3. Check the Accept labels in formulas check box.
4. Click OK.

Functions

NOW Function
When you want to show the current date at the top of a worksheet, or if you want to calculate how long an employee has worked for you to date, you can use the NOW function. It enters the current date and time as a result in the cell. Whether or not both the date and time display in the result cell depends on how you format the cell containing the formula.

To enter the NOW function in a formula:
1. Type the formula up to the point where you want to insert the NOW function.
2. Type NOW(). The NOW function contains no arguments.
3. Continue typing your formula until you are done and press Enter.

You can apply different date and time formats to a cell to format the display of the result of the NOW() function.

To apply date and time formats:
1. Select Format > Cells. This opens the Format Cells dialog box.
2. Select the Number tab.
3. Select Date or Time from the Category list and select the desired format from the Type list.
4. Select OK.

DATE Function
The DATE function translates a date entry into a value so it can be used in a formula that calculates a date based on some other date. The format of the DATE function is year, month, day, in that order. So the function would be written =DATE(year, month, day). The arguments can be written as a constant value, a reference to a cell, or a date calculation.

To use the DATE function:
1. Type DATE().
2. Enter the year argument by either typing a number (like 2005), clicking on the cell that contains only the year, or type a formula whose result can only be interpreted as a year (like 2005 +3).
3. Type a comma.
4. Enter the month argument as either a number between 1 & 12, by clicking on a cell that contains only the number of the month, or typing a formula whose result is between 1 and 12. The month cannot be entered as text, such as February.
5. Type a comma.
6. Enter the day argument as either a number between 1 and 31, by clicking on a cell that contains only the number of the day, or typing a formula whose result is between 1 and 31.
7. Type the end parentheses ).
8. Continue entering your formula and press Enter.

If you want to calculate a time value, you would use the TIME function. Time is calculated in military hours, so 5pm would be the number 17. The function is written =TIME(hour, minute, second).

If you want to show just a portion of a date, such as the year, you can use the YEAR, MONTH, or DAY functions. If you wanted to extract the current year from a date you would type =YEAR(NOW()).
Date Calculations

A date calculation is a formula that results in either a new date, or a date value, such as 6 months. You can create new dates by adding or subtracting from other dates.

For example, if you wanted to calculate the date for an employee's annual review, there are two ways you can use the Date function to calculate the date.

- Type \(=\text{DATE(year(b3)+1, month(b3),day(b3))}\). This adds one year to the date that you have in cell b4. You can add or subtract any values from the year, month or day to create a new date.
- Type \(=\text{DATE(2001+1,4,23)}\). This adds one year to the date.

If you want to calculate how many days an employee has been with you, you could use a formula such as this: \(=\text{NOW()-D8}\). If cell D8 contains the employee's hire date (for example, 4/23/01), then Excel would take today's date and subtract 4/23/01 from it. The result would be the number of days that person has worked for you. If you want the results in years and months, you would use the DATEDIF function. The DATEDIF function is written \(=\text{DATEDIF(olderdate,newerdate, "result")}\). The "result" would be a "Y" if you want the result returned in years, or "M" if you want the result returned in months.

IF Function

If you want to compare two values, and based on that comparison return one value if true and another value if false, you would use the IF function. With the IF function, you can create a formula that sets up a certain condition, such as "Is the amount more than $200.00," then tell Excel what to do if the answer is true, and something else to do if the answer is false.

The IF function is written \(=\text{IF(condition, condition if true, condition if false)}\).

- The condition is a comparison between two variables. The comparison is set up using an operator (a mathematical symbol). Operators for Excel are:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
</tr>
</tbody>
</table>
The **condition if true** part of the function can be written as a value (numeric or text), a cell reference, or a formula.

The **condition if false** part of the function can be written as a value (numeric or text), a cell reference, a formula or can be left blank. If you leave the **condition if false** blank, the word **false** is placed in the cell by default.

Let’s say you are keeping track of your employees’ professional development hours. Employees need to complete 12 hours. In your results column, you want to show how many remaining hours the employee needs to reach 12. If the employee has reached 12 or more hours, you want the cell to read “complete.” You would write the formula as shown in cells D2 and D8:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Employee</strong></td>
<td><strong>Workshop Title</strong></td>
<td><strong># of Hours</strong></td>
</tr>
<tr>
<td>2</td>
<td>John Johnson</td>
<td>Microsoft Excel Basics</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>Datatel UI</td>
<td>Conflict Resolution</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td>1.5</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td>Total 4.5</td>
</tr>
<tr>
<td>6</td>
<td>Greta Harper</td>
<td>Powerpoint 1</td>
<td>2</td>
</tr>
<tr>
<td>7</td>
<td></td>
<td>ADA Awareness Training</td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td></td>
<td>Total 3</td>
<td></td>
</tr>
</tbody>
</table>

When you create a worksheet and have not entered data into the cells yet, the **IF** function can be used to keep errors from appearing. For example, if you enter the formulas into cells as shown below, you would get a **#DIV/0!** error. Since there is no data, you are asking Excel to divide by zero, which will bring up errors.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Campus</strong></td>
<td><strong># of visits</strong></td>
</tr>
<tr>
<td>2</td>
<td>NRG</td>
<td>=b2/$b$5</td>
</tr>
<tr>
<td>3</td>
<td>EVC</td>
<td>=b3/$b$5</td>
</tr>
<tr>
<td>4</td>
<td>PIN</td>
<td>=b4/$b$5</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>=SUM(b2:b4)</td>
</tr>
</tbody>
</table>

However, if you write the formulas as shown below, you will not receive the errors.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Campus</strong></td>
<td><strong># of visits</strong></td>
</tr>
<tr>
<td>2</td>
<td>NRG</td>
<td>=IF(b5=0,&quot;&quot;,b2/b5)</td>
</tr>
<tr>
<td>3</td>
<td>EVC</td>
<td>=IF(b5=0,&quot;&quot;,b3/b5)</td>
</tr>
<tr>
<td>4</td>
<td>PIN</td>
<td>=IF(b5=0,&quot;&quot;,b4/b5)</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>=SUM(b2:b4)</td>
</tr>
</tbody>
</table>

With the **IF** function written this way, if cell b5 is equal to zero the cell will remain blank.

To create more elaborate **IF** arguments, up to seven **IF** functions can be nested as the **value_if_true** and **value_if_false** arguments.
PMT Function
The PMT function is a financial function. It can be used to calculate different results depending on the information you give. This function will allow you to calculate monthly payments on a loan, or interest earned on an investment.

The PMT function is written in a few ways:

- \[ \text{PMT}(\text{rate}, \text{number of payments}, \text{loan amount}) \] to calculate loan payments.
- \[ \text{PMT}(\text{rate}, \text{number of payments}, \text{future value}) \] to calculate amount you need to invest now to reach some future goal.

**Note:** In the PMT function, if you are the one making the payments, the loan amount must be preceded with a minus sign (-). Excel treats this as a debit from your account and will return a positive result. If you will be receiving the loan payment, you will want to leave off the minus sign and Excel will treat it as a credit to your account.

For example, if you wanted to calculate what the monthly payment would be on a $15,000.00 loan at annual interest rate of 6% for 3 years, you would write the formula \[ \text{PMT}(0.06/12, 3\times12, -15000). \]

The formula is broken down as follows:

- \( 0.06/12 \) - To get the monthly interest rate, you would divide the annual interest rate by 12 months.
- \( 3\times12 \) - Again, to get the number of monthly payments, you would multiply the number of years by 12 months.
- \(-15000\) - The amount of the loan written with a minus sign.

Lookup Tables
The purpose of a lookup table is to look up data in a table. There are 2 main types of lookup tables:

- **VLOOKUP.** This is a vertical lookup. You first look down vertically until you find the specified argument and then across however many columns to find the data. The function is written \[ \text{VLOOKUP}(\text{value}, \text{range to search}, \text{column number}). \]

- **HLOOKUP.** This is a horizontal lookup. You first look across columns until you find the specified argument and then down the rows. The function is written \[ \text{HLOOKUP}(\text{value}, \text{range to search}, \text{row number}). \]

For example, you can use the lookup function as a way of applying letter grades to numerical scores. In the following table, you have a list of students with their numerical scores. You also have a table listing the letter grade with the corresponding numerical values.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>ID</td>
<td>Last Name</td>
<td>First Name</td>
<td>Score</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>23356</td>
<td>Rogers</td>
<td>Kelly</td>
<td>98</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>33654</td>
<td>Crasden</td>
<td>Craig</td>
<td>85</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>77384</td>
<td>Ridges</td>
<td>Valmer</td>
<td>93</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td>Range</td>
<td></td>
<td>Letter Grade</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td>50</td>
<td></td>
<td>F</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td>60</td>
<td></td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td>70</td>
<td></td>
<td>C</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td>80</td>
<td></td>
<td>B</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td>90</td>
<td></td>
<td>A</td>
<td></td>
</tr>
</tbody>
</table>
In the Grade column for Kelly Rogers, we would write the formula =VLOOKUP(D2,B9:C13,2). The formula is broken down as follows:

- **D2** - This is the value we are looking up. The score for Kelly (98) is located in cell D2.
- **B9:C13** - This is the range where we want to search for our value. As you see, 98 is not located in the range. Excel then searches for the next lowest value, which would be 90.
- **2** - This is the column number in the range for which we want to return the value. The Letter Grade is located in the 2nd column of the specified range. This returns the grade letter A.

**Using Multiple Sheets and Workbooks**

Refer to cells in other worksheets and workbooks

When writing formulas you may need to refer to cells or ranges in other worksheets or workbooks. Some basic rules when referencing cells and cell ranges from other worksheets in the same workbook are:

- The cell reference is preceded by the name of the remote worksheet and an exclamation point (!). For example, sheet2!B5 or grades!C3:E14.
- When you change the name of a worksheet, any remote references to cells or ranges in the renamed worksheet will automatically be edited to reflect the name change.
- When referring to a worksheet whose name contains a space, you should enclose the worksheet name in 'single quotes'. For example, 'English 1311'!$B$7.
- If you want to refer to a named range in another worksheet, you can type the name into your formula. For example, say you want to reference a range named totals in a worksheet named sales. You would write the formula =SUM(sales!totals).

Basic rules when referencing cells and ranges from other workbooks are:

- The cell reference and worksheet are preceded by the workbook name surrounded in brackets ([ ]). For example, [exercises.xls]sheet2!H7.
- If the name of the worksheet contains spaces, the single quotes surround the name of the workbook as well. For example, '[excel_exercises.xls]student totals'!c2:H10.
- If the name of the workbook contains spaces you would use single quotes to surround the workbook and worksheet names. For example, '[excel exercises.xls]exercises'!A5.

**3D Formulas**

A 3-D formula refers to a cell or range located in the same place on two or more worksheets. To use 3-D formulas, you create a set of multiple worksheets with the same arrangement of cells for each item you want to analyze. For example, say you had several invoices, each on their own worksheet, that you want totaled. On each of the sheets, the “amount owed” appears in the same location in each worksheet. You would then write a 3-D formula referencing every “amount owed” cell on the worksheets.

A 3-D formula is created by using a 3-D reference. Rules for creating 3-D formulas are:

- The 3-D reference is written FirstSheet:LastSheet!FirstCell:LastCell. For example, Invoice2:Invoice12!B4:F12.
- 3-D reference range can refer only to worksheets that are located in the same workbook.
- The 3-D reference cannot refer to non-adjacent worksheets in a workbook. For instance, you cannot refer to the first, third and fifth worksheets, only to worksheets whose tabs are adjacent to one another.
- Worksheet names that contain a space must be enclosed with ‘single quotes’. For example, ‘grades:all scores’!H8.
Audit A Worksheet

If you encounter a problem with one of your formulas, you can use the Auditing toolbar to locate possible problems with formulas and values within your worksheet. The toolbar will graphically trace relationships between cells and their formulas.

To display the Auditing toolbar:
1. Select Tools > Formula Auditing.
2. Select Show Auditing Toolbar.

1. **Error Checking.** Clicking This button begins the error checking process.

2. **Trace Precedents & Remove Precedent Arrows.** Displays arrows to cells that are referred to by a formula in another cell. Removes the arrows.

3. **Trace Dependents & Remove Dependent Arrows.** Displays arrows to cells that are contained in the formula in the current cell. Removes the arrows.

4. **Remove All Arrows.** Removes all precedent and dependent arrows.

5. **Trace Error.** Displays arrows to cells that cause the error in the cell.

6. **New Comment.** Add a comment to a cell.

7. **Circle Invalid Data & Remove Invalid Data Circles.** Displays circles around cells that do not meet their data validation criteria. Removes the circles.

8. **Watch Window.** Allows you to watch cells and their formulas even when they are out of view.

9. **Evaluate Formula.** You can see different parts of a nested formula evaluated in the order the formula is calculated.

**Trace Precedents**
A formula’s precedents are cells to which a formula refers. For example, in the worksheet below, cells B2 and C2 are precedents for the formula shown in cell D2. This means that if the value in either B2 or C2 changes, the value for D2 will change as well.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>April # of Visits</td>
<td>May # of Visits</td>
<td>Total #</td>
</tr>
<tr>
<td>2</td>
<td>RGC</td>
<td>35</td>
<td>42</td>
<td>=B2+C2</td>
</tr>
<tr>
<td>3</td>
<td>RVS</td>
<td>18</td>
<td>39</td>
<td>=B3+C3</td>
</tr>
<tr>
<td>4</td>
<td>Grand Total</td>
<td>=D2+D3</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
When you trace precedents using the **Auditing** toolbar, arrows guide you to the precedents cells.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
</tr>
<tr>
<td>1</td>
<td>Campus</td>
<td># of visits</td>
</tr>
<tr>
<td>2</td>
<td>CYP</td>
<td>62</td>
</tr>
<tr>
<td>3</td>
<td>EVC</td>
<td>112</td>
</tr>
<tr>
<td>4</td>
<td>HBC</td>
<td>51</td>
</tr>
<tr>
<td>5</td>
<td>NRG</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>PIN</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>RGC</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>RVS</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Total</td>
<td>225</td>
</tr>
</tbody>
</table>

To trace precedent values in a cell:
1. Select the cell whose value you want to trace.
2. Click the **Trace Precedents** button from the **Auditing** toolbar. Or, select **Tools > Formula Auditing > Trace Precedents**.
3. When you are finished tracing the precedents, click **Remove Precedent Arrows** button from the toolbar or select **Tools > Formula Auditing > Remove All Arrows**.

**Trace Dependents**

A formula’s dependents are formulas whose results depend on the value in a cell. In the above example, you can trace the dependents for C3 and determine that formulas in D3 and B4 are dependents of C3. In other words, if you change the value of cell C3, the values in cells D3 and B4 will change as well.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
</tr>
<tr>
<td>1</td>
<td>Campus</td>
<td># of visits</td>
</tr>
<tr>
<td>2</td>
<td>CYP</td>
<td>62</td>
</tr>
<tr>
<td>3</td>
<td>EVC</td>
<td>112</td>
</tr>
<tr>
<td>4</td>
<td>HBC</td>
<td>51</td>
</tr>
<tr>
<td>5</td>
<td>NRG</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>PIN</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>RGC</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>RVS</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Total</td>
<td>225</td>
</tr>
</tbody>
</table>

To trace dependents:
1. Select the cell whose dependents you wish to trace.
2. Click **Trace Dependents** button from the **Auditing** toolbar. Or, select **Tools > Formula Auditing > Trace Dependents**.
3. When you are finished tracing the precedents, click **Remove Dependent Arrows** button from the toolbar or select **Tools > Formula Auditing > Remove All Arrows**.
Trace Errors
You can trace an error in your formula using the Trace Error button on the Auditing toolbar. For example, if you had a formula =B2/B3, and cell B3 was an empty cell or had a 0 in it, you would see #DIV/0! in the cell instead of a value. This is because you were trying to divide by 0.

To trace an error in a formula:
1. Select the formula you want to trace.
2. Click the Trace Error button on the Auditing toolbar.
3. An arrow appears, pointing to the cell(s) causing the error.

Data Validation
When you have certain cells or columns/rows that are very specific as to what type of information needs to be entered, you may want to consider working with Data Validation. For example, you can restrict the entry of employee hours to be between 30 & 45.

To add data validation:
1. Select the cell, range, column or row that you wish to add validation.
2. Select Data > Validation.
3. The Data Validation dialog box opens.
4. Select the type of data to allow.
5. Use the Input Message to enter a note/hint on what data needs to be entered.
6. Use the Error Alert tab to enter a message if the data entered is incorrect.
7. Click OK.

To remove data validation:
1. Position your cursor in the cell, range, column or row that you have validation you wish to remove.
2. Select Data > Validation.
3. In the Data Validation dialog box, click Clear All.
4. Click OK.

Data validation does not apply to previously entered data.