Description of Workshop

The purpose of this workshop is to introduce you to the basic features of Macromedia’s Contribute© web page editing program. You will have the opportunity to edit a website that was developed in Macromedia Dreamweaver©. You can learn to use Contribute effectively if you have basic word-processing skills and are familiar with web browsers and the World Wide Web. You do not have to know how to design web pages in Dreamweaver or how to code HTML.

Objectives of the Workshop

In this workshop you will learn the following skills:

1. How to establish a connection to a website
2. How to explore the Contribute workspace
3. How to use Contribute to browse the Web
4. How to open web pages in Contribute and edit them
5. How to create links on web pages
6. How to modify images in Contribute
7. How to publish web pages to a web server after editing them in Contribute

The major reference for this training material was How to Do Everything with Macromedia Contribute, by Doug Sahlin, published by McGraw-Hill/Osborne in 2003. The book may be purchased at local bookstores, or on Amazon.com (www.amazon.com). My copy cost $22.95. I do not recommend buying this book because it was written for an earlier version of Contribute.
I. Introducing Contribute

A. What it Is – Macromedia Contribute is a web site content manager. You can use it to create and edit web pages, edit pictures, manage web sites, and much more. The emphasis in this training is on using the software to edit web pages. You do not have to know how to program in HTML or how to use a web page editing program such as Dreamweaver to learn how to use Contribute.

B. Tasks You Can Accomplish with Contribute – Some of the tasks you can accomplish with this program include:

- Connecting to web sites
- Browsing web pages
- Editing text
- Editing images
- Inserting tables
- Editing tables
- Inserting Flash movies
- Adding and editing links
- Creating new web pages
- Publishing web pages
- Editing frames
- Administering web sites

C. Contribute and Dreamweaver – Contribute and Dreamweaver are both Macromedia products. Designers who use both programs typically design web sites in Dreamweaver and edit them in Contribute. Although you can create new web pages in Contribute, Dreamweaver is a much more robust web page design program.
D. The Contribute Workspace

Figure 1: Contribute Workspace

The How Do I Panel is a valuable reference source for any task you need to accomplish in Contribute. For example, if you click Edit a Page, then click Edit a Page You’ve Connected to, you will find instructions on editing a web page. If you need to find instructions on connecting to a website, click the Connect to a Website link.
II. Connecting to a Web Site

A. Before You Connect to the Site

Before you can edit a web page, you must establish a connection to it. When you establish a connection to a website, the site’s URL is displayed in the address bar of the Contribute document window. Before you can connect to a website you will need your username and e-mail address and the Web address of the site, e.g., http://www.austincc.edu. If you are on an intranet, the address might look something like, \Irtfmp\projects. You will also need your website’s FTP information.

B. Using the Connection Wizard

To use Contribute’s Connection Wizard to connect to a site:
1. Start Contribute.
2. Type the URL of the site you want to connect to in the Address window and press Enter, or click the Go button. Contribute will display a warning that you have not made a connection to the website, as shown in Figure 2 below.

Figure 2: Viewing a site that You Haven’t Created a Connection To
3. Click **Create Connection** to open the **Connection Wizard**, as shown in **Figure 3**.

**Figure 3: Connection Wizard Opening Screen**

4. Click **Next**, and enter your name and e-mail address, if asked. Click **Next**. Type the URL of the website you wish to connect to in the address bar, if you did not do this earlier.
5. Click **Next**. Click the little triangle next to the **How Do You Connect to Your Web** Server box and select the **FTP** option. Enter the name of your FTP server, your FTP login, and your FTP password. **NOTE: All of your information will be different except type of connection (FTP).**

**Figure 5: Connection Information**
6. Click **Next** and Contribute will attempt to connect to your web site host. If it makes a connection, the Connection Wizard Summary screen will display, as shown in **Figure 6**.

**Figure 6: Connection Wizard Summary Screen**

---

**C. Managing Connections**

The main reasons for using Contribute to manage connections to websites are to:

- Remove an obsolete website
- Edit a site when the URL has changed
- Rename a connection

1. **To remove a website connection**:
   a. If you are not working in Edit mode, click **Edit Page** to enter Edit mode.
b. Select any web pages that are open and click **Cancel** or **Publish**. Refer to **Figure 7** as shown below.

**Figure 7: Selecting Publish or Cancel**

![Selecting Publish or Cancel](image)

---

c. Choose **Edit > My Connections** to open the **My Connections** dialog box.

**Figure 8: My Connections Dialog Box**

![My Connections Dialog Box](image)
d. Select the connection you wish to remove from the connections list and click the Remove button. The dialog box illustrated in Figure 9 will ask you to confirm the deletion.

Figure 9: Remove Connection Dialog Box

![Remove Connection Dialog Box]

- e. Click Yes to remove the connection.

2. **To edit a website connection:**

   a. If you are changing your email address or username you must select any draft pages to the Web site you are going to edit and cancel or publish them. Otherwise, you may skip this step.

   - b. Click Edit > My Connections to open the My Connections dialog box, as shown in Figure 8 above.

   - c. Select the website you wish to edit.

   - d. Click Edit to open the Connection Wizard. See Figure 3.

   - e. Navigate through the various screens of the Connection Wizard, as shown in Figures 4, 5, and 6.

   - f. While you are in the Summary Screen dialog box (Figure 6), click the Done button to apply the new settings.

3. **Renaming a Connection**

   When you create a connection to a website, Contribute gives it the name of the title of the site’s home page, for example, COOL Home Page. Follow these steps to rename a connection:

   a. Select Edit > My Connections. The My Connections dialog box opens. (See Figure 8).

   - b. Select the website you wish to rename.
c. Click the **Rename** button to highlight the website name.

d. Type a new name for the site and press **Enter**.

e. Click the **Close** button.

4. **Disabling a Connection**

Contribute’s performance may suffer if you maintain connections to several websites. You can improve the software’s performance by disabling connections you do not want to work with. Follow these instructions to disable a connection:

a. Choose **Edit > My Connections** to display the My Connections dialog box, as shown in **Figure 8**.

b. Select the website whose connection you wish to disable.

c. Click the **Disable** button.

d. Click **OK**. The dialog box closes. A red slash mark appears over the icon to the left of the website’s name, as shown in **Figure 10**.

![Figure 10: Disabling a Connection](image)

e. Unless you want to disable another connection, click the **Close** button to exit the My Connections dialog box.
5. **Enabling a Connection**

Follow these steps to enable a website you have previously disabled:

a. Select **Edit > My Connections** to display the **My Connections** dialog box.

b. Choose the website you wish to enable.

c. Click **Enable** to reestablish a connection to the site.

d. Click the **Close** button.
III. Editing Web Pages

A. Navigating to Web Sites

You can use Contribute to navigate to web pages just as you would use Internet Explorer, Firefox, Netscape, or any other browser. Use one of these methods to navigate to any page on the World Wide Web:

1. Type the URL of the website in the Address window, as illustrated in Figure 11. Note that Contribute warns you that you are viewing a site you have not created a connection to.

Figure 11: Typing URL of Site in Address Bar
2. Click a link on a page you have opened in Contribute. **Figure 12** shows the page that displays when you click the link to **Program Overview** on the Teacher Certification home page.

**Figure 12: Clicking the Link to the Program Overview Page**

![Figure 12](image)

3. Select **View > Go to Web Address**. When the **Web Address** dialog box opens, type the URL of the page you wish to open in the address box. **Figure 13** illustrates this method.

**Figure 13: Web Address Dialog Box**

![Figure 13](image)

To navigate to the home page of a site you have created a connection to, click the **Home Pages** button on the toolbar, as shown in **Figure 14**.

**Figure 14: Home Page Button on Toolbar**

![Figure 14](image)
B. Adding Bookmarks

When you installed Contribute its **Install** utility automatically added the web pages you had bookmarked to your Contribute **Bookmarks** menu. Follow these steps to add a page to your Contribute bookmarks:

1. Type the URL of the page in the address bar and navigate to it.

2. Select **Bookmarks > Add Bookmark**. The **Add Bookmark** dialog box appears, as shown in **Figure 15**.

![Figure 15: Add Bookmark Dialog Box](image)

3. Contribute uses the website’s title as the default name for the bookmark. You may either accept this name for the bookmark or type a new one.

4. Click **OK** to add the new bookmark to the list.
C. Choosing a Page to Edit

You can edit any page that is linked to your website, provided your site administrator has given you permission to edit web pages. Contribute gives you two options for editing web pages: You can edit the page online and then publish it, or you can save a draft of the page, then edit it offline at a later time. To choose a page to edit, do one of the following:

1. Choose **View > Home Pages** and select a home page from the submenu, as illustrated in **Figure 16** below.

   **Figure 16: View, Home Pages**

   ![Figure 16: View, Home Pages](image)

   2. Click the **Home Pages** button and select a page from the menu. **Figure 17** demonstrates this method.

   **Figure 17: Clicking the Home Pages Button**

   ![Figure 17: Clicking the Home Pages Button](image)

   3. Click **Edit** to begin editing the page.
D. Using the Editor Toolbar

The Editor toolbar is shown in Figure 18.

Figure 18: Editor Toolbar

You can use the tools on the Editor toolbar to edit your web pages. The features of the Page Properties tool are covered in section F.

E. Adding Word or Excel Documents and Linking to Them

You can add text to a page by typing it in the document window, or you can import Microsoft Word or Excel documents directly into the page. When you insert a Word or Excel document into a Web page you are editing in Contribute, the program preserves the formatting of the original document. To add content from Word or Excel documents to a web page, you can either:

- Insert the contents of the document into the page. This is recommended for documents of less than 300,000 bytes.
- If the document’s file size is more than 300K, Contribute recommends that you create a link to it.

Follow these steps to insert a Word or Excel document into a web page:

1. Choose the page you want to insert the document into. (See section III. C above).

2. Place the cursor at the point where you want to insert the document.

3. Choose Insert > Microsoft Office Document. The Open dialog box displays.
4. Locate the document you wish to insert, as illustrated in Figure 19.

**Figure 19: Locating a Word Document to Insert in Web Page**

5. To insert the document in the web page, click **Open**.

6. Contribute will display a dialog box that asks how you want to insert the document. Click inside the box that reads “**Insert the contents of the document into this page.**”

**Figure 20: Insert Microsoft Office Document Dialog Box**

7. Click **OK** to insert the document into the web page.
Linking to a Word or Excel Document

If you try to insert a document that is larger than 300K, Contribute will display a warning message. You can cut and paste parts of the document into the web page, or create a link to it, as explained below in this section. When you create a link to the web page you are editing and publish the page, Contribute uploads the linked document to your web site. To link a Word or Excel document to a web page, complete these steps:

1. Choose the web page you want to link the document to.

2. Select Insert on the menu. The Open File dialog box displays. (Refer to Figure 19).

3. Select the document you wish to insert and click Open. The Insert Office Document dialog box appears, as shown in Figure 21.

Figure 21: Linking to a Word Document

4. Click OK to create a link to the file. The name of the file you just created the link to appears on the web page. See Figure 22 below.

Figure 22: Contribute Places the Link on the Web Page
5. The link will not work until you publish the web page. To publish the page, click the **Publish** button on the Contribute toolbar. When Contribute has published your web page you will see a message box similar to the one shown in **Figure 23**.

**Figure 23: Publish Page Dialog Box**

![Publish Page Dialog Box](image)

6. Click on the link Contribute placed on the page to open it in the browser. When you click on the link you will see a message similar to the one in **Figure 24**.

**Figure 24: Open Web Page**

![Open Web Page](image)

7. Click **Open** to open the linked web page in the browser. The web page will open inside Contribute’s web browser.
F. Modifying Page Properties

To modify a web page’s properties:

1. Open the page whose properties you wish to modify in the Contribute document window.

2. Click the **Edit Page** button.

3. Click the **Page Properties** button. The **Page Properties dialog box**, as shown in **Figure 25**, will display.

![Figure 25: Page Properties Button]

4. The **Page Properties** dialog box lists four categories of objects whose properties may be changed: Title/Encoding, Appearance, Links, and Headings.

5. **Title/Encoding** – The page title appears in the title bar of the browser when a page is opened on the Web. You can change the title of the web page by highlighting and typing over the current title. **Encoding** should be set to Western European. You should never have to change this setting.
6. **Figure 26** shows the properties that may be changed under the Appearance category. They are:

   a. **Page text** – Font, font size, text color
   b. **Background** – Background color, background image
   c. **Page margins**

Figure 26: Changing the Web Page’s Appearance Properties

7. **Changing appearance of links** – As illustrated in **Figure 27**, Contribute gives you the option of changing the appearance of the links on a web page.

Figure 27: Changing Appearance of Links
You have the option of changing the following properties of a web page’s links:

a. **Link color** – You may change the color of the text links on a web page.

b. **Visited links** – A link to a URL that the visitor to the web page has already viewed.

c. **Active link color** – The color of links before the visitor clicks them.

d. **Rollover links** – A link’s color changes when the mouse is rolled over it.

8. **Other properties** that may be changed in this dialog box:

a. **Link font** – It is best to not change this property. Web pages look better when the page’s text and links share the same font.

b. **Underline style** – You can choose from the following underline styles: Never underline, always underline, show underline on rollover, and hide underline on rollover.

9. **Headings** – From this dialog box you can make these changes:

   a. Heading font
   b. Heading size
   c. Heading color

**Figure 28: Changing Headings**
G. Undoing and Redoing Actions – Contribute allows you do undo, or redo, the last edit you have done.

1. To undo an action, choose Edit > Undo Typing.
2. To redo an action, choose Edit > Redo Typing.

Figure 29: Undo and Redo

H. Deleting a Web Page

You can delete a page at any time if your website administrator has given you permission to delete pages. To delete a web page follow these steps:

1. Click File on the menu at the top of the Contribute workspace.
2. Select Actions, and then select Delete Page.
3. When the alert box appears, click Yes to confirm that you want to delete the page.

I. Saving a Page Draft

Contribute saves a draft of the page when you click the Edit Page button. To save a draft of a page while you are working, select File > Save.
J. Canceling Edits

You can cancel edits you have made before publishing a page or saving it as a draft, or you can also cancel any drafts you have previously saved. To cancel a draft:

1. If you want to open a page you are not currently editing, select the draft from thePages panel.

2. Click the Cancel button, or select File > Actions > Cancel Draft.

3. Click Yes in the dialog box that asks you to confirm the operation.

Figure 31: Cancel Edit

K. Using the Pages Panel

The Pages panel appears to the left of the document window, as shown in Figure 32. You can do the following operations in the Pages panel:

1. Select pages you want to view

2. View the web page currently displayed in the browser.

3. While you are viewing a web page, you can select a page draft to edit by clicking its name in the Pages panel.

4. If you are editing a page draft, you can switch to another page draft by clicking its title in the Pages panel.
5. You can switch to Browse mode by clicking **Browser** in the Pages panel.

**Figure 32: The Pages Panel**

---

**L. Printing a Web Page**

Follow these steps to print a copy of a web page:

1. Select **File > Print**. In the Print dialog box change any options you wish to change.

2. Click **Print**.

**M. Previewing a Page in the Browser**

To preview a web page in the browser, follow these steps:

1. Be sure you are working in **Edit** mode. Select the page you want to preview in the browser.
2. Select **File > Preview in Browser**. The dialog box shown in **Figure 33** will appear. You can also preview a page in a browser by pressing the **F12** key.

![Figure 33: Preview in Browser Dialog Box](image)

3. Click **OK** to close the dialog box and display the draft in your default web browser.
IV. Working with Text

A. Adding Text

You can use either the following three methods to add text to a web page in Contribute:

1. Click inside the document window and begin typing, just as if you are typing a document in a word processor.

2. Select a block of text typed in Microsoft Word, or another program, drag it into your Contribute web page, and drop it at the location where you want the text to appear. (NOTE: I tried to drag and drop a piece of text from this document into a Contribute page, but could not do it. This method only works with programs that allow you to tile windows. You cannot do this in Contribute).

3. Select a block of text typed in another program, copy it to the clipboard, and paste the copied text into the Contribute document. This method is demonstrated in Figure 34.

Figure 34: Copying Word Text into Contribute Web Page

B. Adding the Date to a Web Page

When you revise a web page it’s a good idea to insert the revision date in it. Follow these steps to add the current date to a web page:

1. Type “Revised on:”, then press the space bar to insert a space.
2. Choose **Insert > Date**. The **Insert Date** dialog box displays, as shown in **Figure 35**.

**Figure 35: Insert Date Dialog Box**

3. Select the day format you wish to use from the **Day format** field. The default option does not display the day.

4. Select the date format from the **Date format** field.

5. If you want to display the time the web page was revised, select a time format from the **Time format** field.

6. Click the **Update automatically on save** check box, and then click **OK** to insert the date in the web page. **Figure 36** shows the current date and time added to the COOL Grant home page.
C. Inserting Special Characters

Contribute allows you to insert special characters such as the copyright symbol © to your text. To insert a special character:

1. Place the cursor where you want the special character to appear.

2. Choose Insert > Special Character from the submenu that displays, as illustrated in Figure 37, or:
3. Select Insert > Special Character > Other to open the Insert Other Character dialog box. Click the character you wish to insert, then click OK.

4. Figure 39 shows the copyright symbol inserted in a web page.
D. Formatting Text

1. Changing font and font size

When changing the font size of selected text, you will only be able to select a font size from the pop-up menu. In other words, you cannot type a size that is not on the menu in the Font field. To change a font size, follow these instructions:

   a. Highlight the word or phrase whose font size you want to change.
b. Do one of the following to select the text size:

- Choose **Format > Size** and choose one of the preset font sizes. **Figure 40** illustrates this method.

**Figure 40: Using Format > Size to Change Font Size**

- Click the small triangle to the right of the right of the **Font Size** tool button on the **toolbar** and select the new font size from the pop-up menu. This procedure is illustrated in **Figure 41**.
To change the font, or font type, use one of the two methods explained above, except select **Format > Font** on the menu, or select the name of the font from the **Font** field on the toolbar. **Figure 42** shows the fonts that are available in Contribute. In your web pages you should usually use one of these fonts, because they can be displayed by most web browsers. *(NOTE: Many Macintosh users use the Helvetica font on their web pages. It is similar to the Arial font.)*

**Figure 42: Fonts Available in Contribute**
2. Changing font color

To change the color of a piece of text:

a. Select the text whose color you are going to change.

   - Choose **Format > Text Color**, or

   **Figure 43: Pop-Up Color Palette**

   ![Color Palette](image)

   - Click the **Text Color** button, as shown in **Figure 44**. Either way, the pop-up color palette, shown in **Figure 43**, appears.

   **Figure 44: Text Color Button on Toolbar**

   ![Toolbar with Text Color Button](image)

b. Drag the cursor over the color swatches until you find the color you wish to use. Click the left mouse button on the color you want to select. Contribute applies the selected color to the text.
3. Aligning text

Web page text is left-aligned by default, but you can center, right-align, or justify text, the same as in a word processing program. To align text, follow these instructions:

a. To align a word, phrase, sentence, or paragraph, either place the cursor inside it or select it. To align more than one paragraph, select each paragraph.

b. You can use one of these two ways to align text:

- Choose **Format > Align** from the menu, then choose one of the four options from the submenu. (See **Figure 45**).

**Figure 45: Selecting Format > Align from the Menu to Align Text**
• Click the alignment option you wish to apply from the toolbar, as shown in Figure 46.

Figure 46: Text Align Buttons on Toolbar

4. Creating lists

You can organize your information into four different kinds of lists in Contribute. They include:

- **Numbered lists** – Each item in the list is preceded by a number.
- **Bulleted lists** – Each item in the list is preceded by a bullet.
- **Definition lists** – Every item in the list is followed by the definition of the item, and the definition is indented.
- **Sublists** – You can create a sublist for an existing list. Each item in the sublist is indented and preceded by a different style of number or bullet.

**Creating a Numbered List**

To create a numbered list:

a. Click the left mouse button at the place where you want to numbered list to appear.
b. Do one of the following to format the text you type as a numbered list:

- From the menu select **Format > List > Numbered List.** This step is illustrated in **Figure 47.**

**Figure 47: Using the Menu to Create a Numbered List**
• An alternative method is to Click the **Numbered List** button on the toolbar. The **Numbered List** button is shown in **Figure 48**.

**Figure 48: Numbered List Button**

![Numbered List Button](image)

c. Contribute inserts the number “1.” Type the text for the first item in the numbered list.

d. Press **Enter** and the next item will be added to the numbered list. Press **Enter** for each new item in the list.

e. You can disable numbering when your list is complete by pressing **Enter** twice.

**Creating a Bulleted List**

To create a bulleted list:

a. Place the cursor where you want to insert the list

b. You can use either of these techniques to create the bulleted list:
• Select **Format > List > Bulleted List** from the menu, as shown in **Figure 49**.

**Figure 49: Using the Menu to Create a Bulleted List**

- Click the **Bulleted List** button on the toolbar, as shown in **Figure 50**.

**Figure 50: Bulleted List Button on Toolbar**

c. A bullet is inserted before the first item in the list. Type the first item and press **Enter** to insert a bullet for the second item. Each time you type an item in the list and press **Enter**, Contribute inserts a bullet.

d. When you finish typing the list, press **Enter** twice to end the bulleted list.
Creating a Definition List

To create a definition list, follow these instructions:

a. Position the cursor at the place in your page where you want to insert the definition list.

b. On the menu choose **Format > List > Definition List.**

   **Figure 51** illustrates this step.

   **Figure 51: Selecting Format > List > Definition List**

   ![Selecting Format > List > Definition List](image)

   c. Type the definition of the term.

   d. Press **Enter.** Contribute increases the indentation of the next line, or outdents it.
e. When you are ready to end the definition list, press Enter twice. Figure 52 shows an example of a definition list.

**Figure 52: A Definition List**

```
font
  a typeface in a particular style
font size
  the height of a character
pont
  One seventy-second of an inch
```

**Creating a Sub List (Nested List)**

If you wish you can nest a list within another list. A list nested inside a list is called a sublist. Contribute allows you to nest a bulleted list inside another bulleted list, a bulleted list within a numbered list, etc. To create a sublist within an existing list item, follow these steps:

a. Place the cursor at the end of the list item under which you want to create a sublist.

b. Press Enter. Contribute creates a new list item at the same level of the previous list item.
c. To create a sublist you may either:

- Choose **Format > Indent** on the menu, as illustrated by **Figure 53**.

**Figure 53: Selecting Format > Indent on the Menu**

- Click the **Indent** button on the toolbar, as shown in **Figure 54**.

**Figure 54: Indent Button on Toolbar**

- Press the **Tab** key.

  d. Contribute indents the list and uses this pattern for the rest of the sublist.

  e. After adding each item to the sublist, press the **Enter** key.
f. To return to the parent list, press the **Outdent**, or **Increase Indent**, button on the toolbar. The **Outdent** button is the left-pointing arrow to the left of the **Indent** button on the toolbar. An example of a sublist is shown in **Figure 55**.

**Figure 55: A Sublist**

---

## E. Spell-Checking a Web Page

Using the Contribute **Spell Checker** is very similar to using the one in Microsoft Word. To spell check a webpage, follow these instructions:

1. Choose **Format > Spell Check**, as shown in **Figure 56**. **NOTE:** *Earlier versions of Contribute feature a Spell Check button on the toolbar, but this button was not included in Contribute 3.*
2. The Contribute **Spell Checker** is so similar to the one in Microsoft Word I do not feel further instructions on the use of this tool are needed.
V. Creating Links

In this section of the workshop we will create simple text-based hyperlinks. Learning to create graphic links in a program such as Adobe ImageReady® or Macromedia Fireworks® is a topic that deserves its own workshop. In this part of our workshop we will learn how to make a link to a page draft, make a link to an existing page, make a link to a computer file, and how to make an email link.

A. Making a Link to a Page Draft

To make a link to a page draft or a recently published page, follow these instructions:

1. Select the page draft you are going to place the link in. Click Edit Page.

2. Do one of the following to indicate the location of the link in the web page:
   - Place the cursor at the spot where the link will appear.
   - Select the text that will be used for the link, as shown in Figure 57.

Figure 57: Selecting Text for Link
3. There are several methods you can use to open the **Insert Link** dialog box, but we will only discuss one of them. From the menu at the top of the document window select **Insert > Link > Drafts and Recent Pages**. This step is illustrated in **Figure 58** below.

**Figure 58: Insert Link from Menu**

4. The **Insert Link** dialog box, which is shown in **Figure 59**, opens.

**Figure 59: Insert Link Dialog Box**

5. Select the page you are linking to from the list under the **Select a page to link to** list.

6. Click **OK**. The link is placed on your page draft or recently published page.
B. Making a Link to a Computer File

Use this method to create a link to a web page or file that is stored on your computer or external storage media. The page I am using in this example is a copy of the home page of the COOL Grant website. To create the link, follow these steps:

1. Select the page you are going to place the link in.

2. Select the text you wish to use for the link.

3. Choose Insert > Link > File on my Computer to open the Insert Link dialog box. This step is illustrated in Figure 60.

Figure 60: Selecting a File on Your Computer

4. The Insert Link dialog box opens. Click the Browse button to open the Select File dialog box. These two dialog boxes are shown in Figure 61.
5. Click **Select** to close the **Select File** dialog box. Click **OK** to place the link in the page and close the **Insert Link** dialog box.

### C. Making a Link to an Existing Page

Use this method to create a link to an existing web page. In this example we create a link to the ACC home page, but you may create links to other pages on your website that are not drafts and have not been recently published. To create a link to a page on the World Wide Web, follow these steps:

1. Select the text you wish to use for the link.
2. Choose **Insert > Link > Browse to Web Page** to open the **Insert Link** dialog box.

![Figure 62: Browse to Web Page](image)

3. Type the URL of the web page you are linking to in the **Web Address (URL)** box, as illustrated in **Figure 63**.

![Figure 63: Type URL of Site to Link To](image)

4. Click **OK** to insert the link.
D. Making an Email Link

To make a link to an email address, follow these instructions:

1. Open the page to which you want to add an email link.
2. Select the text you want to create the link to.
3. Choose Insert > Link > E-mail Address from the menu. The Insert Link dialog box opens.

Figure 64: Insert Email Link

4. Enter the user’s email address in the E-mail Address field of the Insert Link dialog box. (For example, jclark@austincc.edu.)

Figure 65: E-Mail Address Field
5. Click OK to insert the email link. The link is underlined in blue, as shown in Figure 66.

**Figure 66: Email Link Displayed on Web Page**

Email Jimmy Clark at: jclark@austincc.edu
VI. Working with Images

You can use Contribute to add or delete an image on a web page, to replace an image, or to change an image’s properties. You can also use Contribute to reposition an image on a page.

A. Inserting an Image into a Web Page

Contribute supports images with any of these extensions: .jpg, .jpeg, .jpe, .jfif, .gif, and .png. There are three ways you can insert an image in a page you are editing with Contribute:

- Choose **Insert > Image** from the menu.
- Click the **Image** button on the toolbar.
- Drag an image from another program into the page you are editing.

We will only discuss using **Insert > Image** on the menu to add an image to a web page. To insert an image that is stored on your computer in a page draft, follow these instructions:

1. Position the cursor at the point in your web page where you want to add the image.
2. Choose **Insert > Image** on the menu at the top of the workspace.
3. Select **From My Computer** from the pop-up menu. This step is illustrated in **Figure 67**.

**Figure 67: Insert Image**

![Image of pop-up menu with insert options](image)

4. The **Select Image** dialog box opens. Locate the folder that contains the image you want to place in the web page and click on that image to highlight it. Click the **Select** button to insert the image in the web page.

**Figure 68: Selecting the Image to Insert**

![Image of select image dialog box](image)
5. **Figure 69** shows the image placed in the web page.

![Figure 69: Image Inserted in Web Page](image)

**B. Deleting an Image**

To delete an image:

1. Select the image.

2. Do either of the following:
   - Select **Edit > Cut**.
   - Press the **Delete** key.
   - Press the **Backspace** key.

**C. Modifying an Image**

The most common modifications you will make to an image in Contribute will be changing its alignment and size. To change the alignment of an image:
1. Select the image. The **Image Editing** toolbar displays near the top of the document window. The image toolbar is illustrated in **Figure 70**. (If the **Image** toolbar does not display, right-click on the image and choose **Image Properties**).

**Figure 70: Image Editing Toolbar**

2. Use the alignment buttons shown in **Figure 70** to change the alignment of the image.

3. To change the size of an image, type the new sizes in the **Width** and **Height** boxes shown in **Figure 70**.

4. You may manually resize an image by clicking the **Image Resize** button, shown in **Figure 71**. If you want to keep the image’s proportions the same, click the lower right corner of the image and drag the selection handle up and to the left, or down and to the right. The **Crop** button may be used to delete part of an image. To crop an image, click the **Crop** button to select the image, and then one of the sizing handles over the portion of the image you want to keep. Press **Enter** to crop the image.

**Figure 71: Image Resize Button**
VII. Publishing a Web Page to a Web Server

A. Previewing an Edited Page

It is a good idea to preview a page when it is ready to publish to verify that it looks good in the browser and make sure all the links work correctly.

Figure 72: Preview in Browser

1. To preview a web page draft in the browser, do one of the following:
   - Select File > Preview in Browser on the menu.
   - Press the F12 function key on the keyboard.

2. It is advisable to preview your web pages in at least two browsers before publishing them to the web server. I preview my web pages in Internet Explorer, Mozilla Firefox (www.mozilla.org), Internet Explorer for the Macintosh, and Apple’s Safari browser. You have to have access to a Macintosh computer to preview your web pages in the Internet Explorer for the Macintosh and Safari.

B. Publishing Web Pages

You can use Contribute to publish the following types of web pages to your web server:
   - Edited versions of existing web pages
   - New web pages that you have not previously published to your web server
   - Edited versions of existing pages as new pages
1. **Publishing a New Web Page** – To publish an edited version of an existing page:

   a. Select the page draft that you are going to publish.

   b. If the page you are publishing is linked to an existing page, Contribute publishes the new page.

   c. If the page you are about to publish is not linked to an existing page, the following message appears:

   Figure 73: Link to Existing Page Message Box

   ![Link to Existing Page Message Box](image)

   d. If this message appears, click No, and link the new page to an existing page before you publish it.

   e. If the page you are publishing is linked to an existing page, the **Publish New Page** dialog box appears, as shown in Figure 74.

   Figure 74: Publish New Page Dialog Box

   ![Publish New Page Dialog Box](image)
f. You can type a new filename for the web page in the **Filename** box if you want to change the filename.

g. Click **Publish** to publish the new page to the web server.

h. When the page has been published to the server, the message box displayed in **Figure 75** will display.

**Figure 75: Published Page Message Box**

![Figure 75: Published Page Message Box](image)

2. **Publishing an Edited Version of an Existing Page** – To publish an edited version of an existing page, follow these steps:

a. Select the page draft you want to publish.

b. Click the **Publish** button. If you have created a new page that is linked to the page draft you are publishing, the **Publish New Linked Pages** dialog box appears. This dialog box is shown in **Figure 76**.

**Figure 76: Publish New Linked Pages Dialog Box**

![Figure 76: Publish New Linked Pages Dialog Box](image)
c. You may change the filename of the linked page if you want to.

d. Click the **Publish All** button to publish all the linked new pages.

e. When Contribute has published your web pages, the message box displayed in **Figure 75** will display.

3. **Reverting to a Prior Version of a Page**

You can roll back to a previous version of a recently published page because Contribute creates a copy of your original page when you edit an existing page and publish it. The default number of rollbacks is three, but the site administrator may specify a larger or smaller number of them. Follow these steps to rollback to a previous version of a web page:

a. Find the web page you want to rollback to a previous version.

b. On the menu at the top of the Contribute workspace choose **File > Actions > Roll Back to Previous Version**. NOTE: If this option is grayed out, the site administrator has disabled it. **Figure 77** illustrates this step.

**Figure 77: Choosing File > Actions > Roll Back to Previous Version**
c. If you are trying to rollback a page you are editing, you will see the message box shown in Figure 78. If you get this message, click OK, and then publish your changes to the page, then repeat steps a and b again.

Figure 78: Rollback Error Message

![Rollback Error Message](image)

d. If you are not trying to rollback a page that you are editing, the Roll Back Page dialog box (Figure 79) will display. Select the version of the page you want to rollback to and click the Roll Back button.

Figure 79: Roll Back Page Dialog Box

![Roll Back Page Dialog Box](image)

e. A preview of the page you are rolling back to will display in the Roll Back Page dialog box. Click the Roll Back button again.

f. The version of the page you rolled back to displays in the Contribute workspace.