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Dreamweaver ® Dimensions 
Presented by Jimmy D. Clark, Instructional Design Specialist, 
Instructional Development Services 
Teaching and Technology Trends Symposium – October 21, 2005 

Welcome to Dreamweaver ® Dimensions at Teaching and Technology Trends Symposium. This three‐ 
hour workshop covers the basics of developing a website using Macromedia Dreamweaver MX. In this 
workshop we will plan our website, build it in Dreamweaver, enhance it with navigation bars and 
images, and upload it using Dreamweaver FTP. 

I. Planning Your Website 

From my experience as a website designer I have learned the hard way that the most valuable time I 
spend in developing a site is the time I spend planning it before I open Dreamweaver and begin creating 
the web pages. It is much easier to design your web pages on paper first, then create them in 
Dreamweaver than to build the pages in Dreamweaver and have to redo them. At Macromedia’s support 
site (http://www.macromedia.com/support/dreamweaver/layout/site_planning/ ) Macromedia 
suggests a five‐step planning process: 

1. Create goals for your site 
2. Organize the site structure 
3. Create your design look 
4. Design the navigation structure 
5. Plan and gather your assets 

1. Create Goals for Your Website 

Why do you need to have a site on the World Wide Web, which already has over 8 billion pages on it, 
according to one estimate (http://www.cyveillance.com/web/newsroom/stats.htm)? Do you want to 
use your site as teaching aid in your classes, build a site for your department at ACC, inform us about 
your hobbies, sell products or services, save the environment? These are just a few of the reasons 
people having for putting sites on the Web. Establishing the goals for your site will help you design a 
site that will reach your target audience. 

Examples of sites with different goals: 

‐ Jimmy Clark’s website for his course in website design: http://www.austincc.edu/jdclark 

‐ Website of Instructional Development Services at ACC: http://itdl.austincc.edu/development/ 

‐ Personal Information Website (Genealogy Page at Roots Web: 
http://freepages.genealogy.rootsweb.com/~kemp/ )

http://www.macromedia.com/support/dreamweaver/layout/site_planning/
http://www.cyveillance.com/web/newsroom/stats.htm
http://www.austincc.edu/jdclark
http://itdl.austincc.edu/development/
http://freepages.genealogy.rootsweb.com/~kemp/
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‐ Commercial Website (Amazon.com: www.amazon.com) 

‐ Website of Charitable Organization: (http://www.redcross.org/ ) 

2. Organize the Site Structure 

If you want to avoid having to spend lots of time reorganizing your site after you build it, you need to 
organize its structure before you build the first page. When you define your site in Dreamweaver you 
create a folder to hold your site. You should create at least one subfolder and use it to store the 
images you place on your pages. The illustration below shows the site folder and other folders for a 
website I created to teach another workshop in Dreamweaver. 

Figure 1: Web Folders 

3. Plan the Site Design and Layout 

The site plan shows how your web pages will look when designed in your website editing program. You 
can create it in Microsoft Word, on paper, or in a program such as Adobe Photoshop. If you need help in 
deciding which color schemes will look good for your web pages, check out this site: 
http://wellstyled.com/tools/colorscheme2/index‐en.html , which lets you test different color 
schemes for your page backgrounds, text, links, etc. Figure 2 shows a mockup my dog created in 
Photoshop for the site he recently built for himself and his friends.

http://www.amazon.com/
http://www.redcross.org/
http://wellstyled.com/tools/colorscheme2/index-en.html
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Figure 2: Web Page Mockup in Photoshop 

4. Design the Navigation Structure for Your Site 

You should design the navigation for your website with the people who will visit your site in mind. Try 
to make your website as easy to navigate as possible and make navigation consistent from page to 
page. If you place a navigation bar at the top of the home page, it should be at the top of all the pages 
of your website. When I am designing a large complex website, sometimes I use colored index cards to 
represent each page. Often I draw a chart on paper showing how each page will be linked to the home 
page and the pages that will be linked to each child page (the pages linked to the home page). Figure 
3 shows the navigation scheme for the website I built for the course I am teaching this semester. The 
boxes represent pages on my website. The underlined pieces of text are links to other pages on other 
websites.
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Figure 3: Navigation Structure for Jimmy’s Website for ITSC 1313
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Several navigation structures are used for websites. Four common navigation structures are: 
hierarchical, linear, hub‐and‐ spokes, and hypertext. The website I designed for my ITSC 1313 class is 
an example of hierarchical navigation. From the home page you can access the other pages on the 
site. Each child page has links to other pages of the website and/or other websites. A linear navigation 
structure forces the visitor to move from page to page in a pre‐determined sequence. (See: 
http://www.nationalgeographic.com/ ). Hub‐and‐spokes architecture features a central hub that the 
visitor returns to in order to launch to another location. Some pages on the National Geographic 
website use this form of navigation. The concept is illustrated in Figure 4. 

Figure 4: Hub‐and‐Spoke Architecture

http://www.nationalgeographic.com/
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There is no starting or ending point in the hypertext navigation structure. The visitor can open any 
page on the site regardless of where he or she started from. This navigation scheme is illustrated in 
Figure 5 below. 

Figure 5: Hypertext Navigation Structure 

5. Plan and Gather Your Assets 

Website design is more efficient when the designer decides which assets (text, graphics, animations, 
etc.) he or she needs before beginning the design process. For instance, you can search for the graphics 
you will place on your site in Microsoft clip art or on the Web, shoot digital photos or video, record 
audio, and type the text for your web pages in your word processor to have it ready to import into the 
web page design program. If you are going to design a template for your website in Dreamweaver, you 
can design the template ahead of time in Word or an image‐editing program such as Photoshop.
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Examples of Good and Bad Design on the Web 

Realizing that “good” and “bad” are in the eyes of the beholder, here are some websites that I think 
illustrate good and bad web design. 

‐ Macromedia’s Website – One of the most attractive sites on the World Wide Web ( 
www.macromedia.com ) 

‐ Beringer Vineyards – Has lots of eye appeal. Uncluttered, easy to navigate ( 
http://www.beringer.com/beringer/index.jsp ). 

‐ Hillman Curtis – Very cutting edge. Gets your attention. Lots of white space. ( 
http://www.hillmancurtis.com/ . 

‐ Horseback Riding Stables and Horse Rentals – Totally rectangular. Only a horse could love this site! ( 
http://www.horserentals.com/ ). 

‐ Honda Motorcars – Compact, easy to navigate, lots of white space. ( 
http://www.honda.com/index.asp?bhcp=1 ) 

‐ Relevare – Has eye appeal, nice animation. (http://www.relevare.com/site/ ). 

‐ Second Story – Cutting edge, grabs your attention, beautiful color scheme (http://secondstory.com/ 
). 

‐ Shutterfly – Simple, user‐friendly. Proves that a website doesn’t have to be cutting edge to appeal to 
visitors. (http://www.shutterfly.com/ ). 

‐ Google – A page I visit many times each day. Very good use of white space. (http://www.google.com/ 
). 

Web Pages That Suck – A website that focuses on poorly‐designed web pages is poorly designed itself. 
Go figure! (http://www.webpagesthatsuck.com/ ).

http://www.macromedia.com/
http://www.beringer.com/beringer/index.jsp
http://www.hillmancurtis.com/
http://www.horserentals.com/
http://www.honda.com/index.asp?bhcp=1
http://www.relevare.com/site/
http://secondstory.com/
http://www.shutterfly.com/
http://www.google.com/
http://www.webpagesthatsuck.com/


8 

If you wanted to design the perfect animal, would you design one that looks like this? This creature is 
perfectly designed to function in its natural environment—proof that form should follow function!
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II. Creating Your Website in Dreamweaver MX 

In this part of our Dreamweaver workshop we will learn the following skills: 
1. How to use the Dreamweaver workspace 
2. How to define (set up) our website 
3. How to create the home page, modify its properties, and save it 
4. How to create a table to hold our page’s content, modify its properties, and add 

content to it 
5. How to work with text in Dreamweaver, which includes using fonts, creating a banner 

heading, creating lists, inserting special characters, and spell‐checking our web page 

Introducing Dreamweaver 

Macromedia Dreamweaver is an extremely popular web design and editing program used by millions of 
amateur and professional web designers. It is part of a suite of Macromedia programs, which include 
Dreamweaver, Flash, Fireworks, FlashPaper, and FreeHand. There are few major differences between 
Dreamweaver MX, MX 2004, and the new version 8. If you can use Dreamweaver MX you will have little 
difficulty switching to one of the newer versions. 

The Dreamweaver Workspace 

Figure 6 shows the Dreamweaver workspace. The Dreamweaver workspace consists of the windows, 
toolbars, and panel groups that are open when Dreamweaver MX is running. 

Figure 6: The Dreamweaver Workspace
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Defining (Setting Up) Our Website 

Before we can create the pages for our website in Dreamweaver, we have to define our site. When we 
define our site we will create folders to hold the files and images that will we use in the pages in our 
website and key in the information needed to use Dreamweaver FTP to upload our web pages. To 
define your website, follow these steps: 

1. Start Dreamweaver. 
2. From the menu bar on the site panel, select Site > New Site to display the Define New 

Site dialog box. 

Figure 7: Site Definition, Step 1 

3. Click the Basic tab to bring it to the front and type “Your Name + Website” in the 
Name Your Site field. Click the Next button. 

Figure 8: Name Your Website
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4. In the next dialog box, select No I do not want to use a server technology and then 
click Next. 

Figure 9: Server Technology Dialog Box 

5. In this step we will tell Dreamweaver where we want to store the files for our website. 
First, verify that the Edit local copies on my machine, then upload to server when 
ready option is selected. In the Where on your computer do you want to store your I 
created a folder on my flash drive named Jimmy Clark’s Website to store the files for 
the website I built for this workshop. Open that folder on the computer you are using in 
this lab. Click Next to advance to the next screen. 

Figure 10: Creating the Site Root Folder
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6. On the next screen Dreamweaver asks you to tell it how you will connect to the remote 
server that will store your website. When you requested a Web account from ACC Web 
Services you received an email that gave you the information you need to enter in the 
following fields. Please remember that the information you will enter when you upload 
you own site will be different. For hostname you will enter www.austincc.edu. For 
folder enter “public_html.” I entered the information show in Figure 11 for the site I 
built for this workshop: 

Figure 11: FTP Session Fields Figure 12: Message after Making Successful Connection 

7. After you enter the information requested in the text boxes show in Figure 11, click 
Test Connection. If Dreamweaver is able to connect with the Web server, you will see 
the message shown in Figure 12. When this message displays, click Next. 

8. The next dialog box asks you if you want to enable checking in and checking out files. 
Select the No option. Click Next. 

Figure 13: Checking in, Checking out Files

http://www.austincc.edu/
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9. Congratulations! You have completed the site definition process. Now you can use 
Dreamweaver FTP to upload your pages from within Dreamweaver. The Site Definition 
Summary screen now displays. Click Done and you are ready to create the home page 
for your website. 

Figure 14: Site Definition Summary Screen
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Creating the Home Page for Our Website 

Now we will create the home page for the website we just defined. After we create the home page we 
will add some content to it and format its text. Then, we will make some other editing changes to the 
page. 

Follow these steps to create the home page: 

1. Select File > New to display the New Document dialog box. 
2. In the Category column, select Basic Page. 
3. In the Basic Page column, select HTML. 
4. Click the Create button to create the page and display it in the document window. 

Figure 15: Creating the Home Page 

To save the web page we just created, complete these steps 
1. Select File > Save As. The File Save As dialog box appears on your screen. 
2. Save the web page in the folder you created to store the files for you website in. 
3. Save your home page as index.htm. 

Figure 16: The File Save As Dialog Box
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Dreamweaver gives each new page the title “Untitled Document.” The title of a web page appears in 
the browser’s title bar when it is opened on the Web. 
Let’s give our web page a descriptive title; 

1. Select Modify > Page Properties to display the Page Properties dialog box. 
2. In the Title box, replace Untitled Document with Home Page and click OK. 
3. You can use the Page Properties dialog box to change a web page’s 

background and some of its other properties. 

Figure 17: Changing the Home Page’s Title 

4. The new title of your home page, “Home Page,” as well as the name of the 
folder you are saving your files in and the file name (index.htm) now appear in 
the title bar of the Dreamweaver workspace. 

5. Check the Site panel on the right side of the Dreamweaver workspace. (If the 
Site panel does not display, click Window, then Site on the menu bar.) In the 
Site panel, the name of your website, the location and name of the folder 
where it is stored, and the filename “index” are displayed. Refer to Figure 18 
below.
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Figure 18: The Site Panel 

6. Save the home page before continuing. Select File > Save.
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Creating a Table to Hold the Web Page’s Content 

After creating the home page for your website, you should create a container to hold its content. 
Usually the content of a web page is contained in tables, frames, or Cascading Style Sheets. CSS is the 
method recommended by the World Wide Web Consortium (www.w3.org), but tables are easier to 
understand and still widely used on the Web. 

Introducing Dreamweaver Tables 

You can either specify the width of a table in pixels or as a percentage of the area displayed in the 
browser window. If you want the width of a table to remain fixed regardless of the size of the browser 
window, specify its width in pixels (example: 760). If you want to allow the width of a table to vary 
with the size of the browser window, specify its width as a percentage (example: 95%). Some terms 
that are used to describe table properties are: 

• Borders – The lines around the boundaries of a table and its cells, the areas in which a 
table’s data is stores. 

• Cell padding ‐ The number of pixels of blank space between the content in a cell and 
its boundary. 

• Cell spacing – The number of pixels between cells. 

You do not have to display the table’s border or specify cell padding or cell spacing. In this part of the 
workshop we will create a table to organize the content of our home page. Then, we will modify some 
of the table’s properties and add some content to it. Study Figure 19. It shows the way we will layout 
our home page. 

Creating a Table for the Home Page 

Figure 19: Home Page Layout Table 

Page Banner 
Horizontal Separator Bar 1 

Top (Global) Navigation 
Left 
(Local) 
Navigation 
Bar 

Left V
ertical Separator 

Page 
Text 

Image 

Bottom Horizontal Separator 
Bottom (Global) Navigation 

Top of Page Link 

Study Figure 19. It shows how we will layout out the home page in the table we will create for it. 
Actually we will create two tables for the home page. The only purpose for the first table will be to 
place a border around our home page. The other table will be the same size and fit inside the first 
table. The only element of the first table the viewer will be able to see will be the border.

http://www.w3.org/
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To create the first table for the home page: 

1. Open the home page if you closed it after Step 6. Select Insert > Table from the menu bar. The 
Insert Table dialog box opens. 

Figure 20a: Insert Table Dialog Box 

2. Enter the settings shown in Figure 20. 

3. To center the table on the page, click anywhere inside the table, select Modify > Table > Select 
Table. In the Property Inspector set Align to Center. 

To create the table we will layout our home page on, follow these steps: 

1. Select Insert > Table from the menu bar. Enter the properties shown in Figure 20. 
2. To center the table, click anywhere inside it, select Modify > Table > Select Table. In the 

Property Inspector, set Align to Center. 

Figure 20: Insert Layout Table 

In the next part of the workshop we will add some content to the layout table.
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Working with Text in Dreamweaver 

Working with Fonts 

There are literally thousands of fonts, but keep in mind if you use fonts that the user’s computer does 
not have installed, the browser will default to Times on a Macintosh or Times New Roman on a PC. 
The following fonts are widely used on web pages and are commonly installed on PCs and Macintoshes: 

Common PC Fonts Common Macintosh Fonts 
Arial Helvetica 
Courier New Courier 
Times New Roman Palatino 
Trebuchet MS Times 
Verdana Verdana 

Arial 

Many web page designers use Microsoft Comic Sans for headings. Most browsers will display this font. 
Study Figure 21. It shows several sets of serif and sans‐serif fonts. The set I generally use for web 
pages is Verdana, Arial, Helvetica, sans‐serif. Some webpage designers use Times New Roman for the 
text of their pages, but it is hard to read on the Web, so I do not recommend using it. If the user’s 
browser cannot display the Verdana font, defaults to Arial, then Helvetica, then sans‐serif. It is best to 
use no more than two or three fonts on a web page. 

Figure 21: Font Lists in Dreamweaver 

Creating a Banner Heading for the Home Page and Laying Out Home Page 

In this step we will create an attention‐grabbing banner heading in the top cell of our home page. 
Complete these steps to create the banner heading: 

1. We must merge the columns in the top row into one wide cell. Click inside the left cell in the top 
row, and then drag across and to the right until you have selected all four cells. 

2. On the menu choose Modify > Table > Merge Cells. The top row should now consist of only one 
cell.
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3. Type your name and title (Ex: Jimmy D. Clark, Adjunct Associate Professor, CIS). Press Shift + 
Enter. Type “Austin Community College.” Select the text you just typed. 

4. Click inside the top cell. From the menu at the top select Text > Font > Comic Sans MS. 

Figure 22: Changing the Font for the Heading 

5. Select the following properties for the banner heading: 
a. Align ‐ Right 
b. Style – Bold 
c. Size – 5 
d. Color – Select any color you like, as long as it does not obscure your text. 

6. Select the cell and change its background color to any color you like using the Property Inspector. 

7. We will place a horizontal separator in the second row of our table. Use the technique you learned 
in Steps 1 and 2 to merge the four cells in row 2 into one. 

8. Make the background of the merged cell a darker color that complements the background color of 
the cell the banner is in. 

9. The next row, row 3, will hold the top navigation bar. It will be a “global” navigation bar because 
all the links in it will open web sites on the World Wide Web. The text‐based links we will type in 
this row are: 
a. ACC Home Page 
b. Course Schedule 
c. ACC Libraries 
d. Student Support 
e. OSD 
f. Blackboard 

10. Select row 3 and merge its four cells into one. Type the text we will turn into links as shown in 
Figure 23. To type the separator bar, hold down the Shift key and type the key below the 
Backspace key. After you type the text links, select them and bold and center them.
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Figure 23: Typing the Text for the Top Navigation Bar 

11. If you wish, change the cell’s background color to one that complements the top banner. 

12. In the left cell of the next row we will create the left, “local” navigation bar. It is called a “local” 
navigation bar because its links will open pages that are in the site we are building (except for the 
one to our department at ACC). The links we will place in the left navigation bar are: 
a. Home Page (of this website) 
b. Home Page of Your Department (Ex: Computer Studies) 
c. My Classes 
d. Course Resources 
e. Meet Instructor 
f. Contact Instructor 
g. My Interests 

13. Set its background color of this cell to one you like. Type the links listed under Step 12. Press Shift 
+ Enter after typing each link to begin each link on a new line without making a new paragraph. 

Figure 24: The Left Navigation Bar 

14. The third column will serve as a vertical separator so that the text we type in our page will not be 
flush against the left navigation bar. Drag the column sizing handle to the left until the column is 
about 10‐15 pixels wide. Place the cursor anywhere in the column and drag down through all its 
cells. Right‐click and from the sub menu that appears select Table > Merge Cells. Leave the
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background color of this cell set to its default color, white, because we do not want the separator bar 
to display on the Web. 

Figure 25: Merge Cells in Vertical Separator 

15. We will use the row under the left navigation bar as a vertical separator to keep the page’s text 
from being flush against the bottom navigation bar. Select all the cells (columns) in this row and 
merge them into one cell. 

16. The row next to the bottom row will hold the bottom global navigation bar. It will contain links to 
every page on the website. Merge the cells in this row. We are going to type fifteen links in this 
row. That is too many to fit on one row. Right‐click anywhere inside this row and select Table > 
Insert Row to add an additional row. Refer to Figure 26 for guidance.



23 

Figure 26: Inserting a New Row in the Table 

17. Type the following links in the merged row, using Arial Bold Size 2 type, separating each link with 
the special character shown in Figure 27. (Insert > Special Character > Other): 
a. ACC Home Page 
b. Course Schedule 
c. ACC Libraries 
d. Student Support 
e. OSD 
f. Blackboard 
g. Home Page 
h. My Classes 

Figure 27: Inserting Special Character 

18. After you type the links in the first row of the bottom navigation bar, select and center the text.



24 

19. Merge the cells in the second row and type the following links in it: 
a. Class 1 (Replace with the name of one of your classes). 
b. Class 2 (Replace with the name of one of your classes). 
c. Your Department’s Home Page (Ex: Computer Studies Home) 
d. Course Resources 
e. Meet Instructor 
f. Contact Instructor 
g. My Interests 

20. Center the text links in this navigation bar. Figure 28 shows the completed bottom navigation bar. 

Figure 28: Bottom Navigation Bar 

21. The last row in the table will contain a link to the top of the home page. This type of link is called 
a named anchor. We will insert a named anchor at the bottom of the name. The target of the link 
will be a labeled location at the top of the page. First we will just type Top of Page in the last row 
(Arial‐Bold‐Size 2 text) and center it. In the next section of the workshop we will make a link to 
this anchor. Merge the cells in this row and type “Top of Page.” Center the text you just typed. 
(EXTRA: You might want to increase the height of this cell and change the vertical alignment to 
Bottom, in the Property Inspector). 

22. We have almost finished laying out our home page. The third column will separate the page text 
from the image we will insert, so make this an extremely narrow column. The second column, the 
page text will go, in will be the widest column. We will adjust these columns as needed later. 
Merge the cells in these three columns as shown in Figure 29, which shows the completed layout of 
the home page. 

Figure 29: Home Page Layout
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III. Enhancing Our Web Page 

Our goals for this part of the workshop are to learn these skills: 

1. How to add links to the navigation bars 
2. How to create the other pages for our website 
3. How to add text to our web pages 
4. How to add images to our web pages 
5. How to print a web page 
6. How to upload our website to the web server using Dreamweaver’s built‐in FTP 
7. How to perform other website operations, such as opening another site for editing 
and closing a website 

Adding Links to the Navigation Bars 

Adding Links to the Top Navigation Bar 

We added the text for our three navigation bars in Part II of the workshop. In this session we 
will add links to the top, left, and bottom navigation bars. Follow these steps to add links to 
the top navigation bar: 

1. Select “ACC Home Page.” 
2. Type “http://www.austincc.edu” in the link box in the Property Inspector. 
3. Follow the same procedure to add the other links: Course Schedule: 

http://www3.austincc.edu/schedule/ 
4. ACC Libraries: http://library.austincc.edu/ 
5. Student Support: http://www.austincc.edu/resources_students/services.php 
6. OSD (Office for Students with Disabilities): 

http://www.austincc.edu/osd/index.html 
7. Blackboard: http://acconline.austincc.edu/ 
8. When you finish adding the links, open the home page in the browser and click 

each one to verify that they work. 

Figure 30: Adding Links to the Top Navigation Bar
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Adding Links to the Left Navigation Bar 

Use these procedures to add links to the left navigation bar: 

1. Home Page (of this website): 
a. Highlight the text “Home Page.” 
b. Click the Browse for File icon in the Property Inspector. 

Figure 31: Browse for File Icon 

c. Navigate to the folder where the home page (index.htm) is stored. 

Figure 32: Making the Link to the Home Page 

d. Highlight “index” and click OK. 
e. The link, “index.htm,” should now appear in the link box in the Property 

Inspector. 

2. Computer Studies Home (home page of your department): Type the URL of your 
department in the Link Box of the Property Inspector.
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3. My Classes – We have not created the other pages of our website, so we will just 
type the names we will use their filenames in the link box. For “My Classes” type 
“myclasses.htm.” 

4. Course Resources – Type “courseresources.htm.” 
5. Meet Instructor – Type “meetinstructor.htm.” 
6. Contact Instructor – Type “contactinstructor.htm.” 
7. My Interests – Type “myinterests.htm.” 

Adding Links to the Bottom Navigation Bar 

The bottom navigation bar will contain links to every page of the website. Use the techniques you used 
to add the links to the top navigation bar and the left navigation bar to add links to this navigation bar. 
Do not add links to “Course 1” and “Course 2.” I just added these pages to the link bar in case you 
need to create other pages for the courses you teach. 

Linking to a Different Location on a Web Page (Named Anchor) 

A named anchor is a link to another location on the same web page. An example is a link at the 
bottom of a page that, when clicked, takes the user to the top of the page. Follow these steps to make 
a link that takes the user from the bottom to the top of the home page: 

1. Place the insertion point to the left of the “J” in Jimmy Clark in the banner at the top of the 
page. 

Figure 33: Inserting a Named Anchor 

2. On the menu click Insert > Named Anchor.
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3. In the Named Anchor dialog box type the name of the anchor, “top.” A small anchor icon displays 
to the left of the letter J in the banner heading. 

Figure 34: Named Anchor Dialog Box 

4. Select the phrase “Top of Page” at the bottom of the home page. Click the Browse for File icon 
and type “#top” in the dialog box. 

Figure 35: Linking to a Named Anchor 

5. You will not see any change in the location of the insertion point when you open the page in the 
browser and test the link because the page is short enough that all of it is displayed in the browser 
window. 

Making an E‐Mail Link 

Follow these instructions to make a link to your email account: 

1. Place the insertion point to the left of the word “Top” at the bottom of the home page. Press 
Enter once. Press the Up Arrow key to create a blank line. Press Enter again. 

2. Type “E‐Mail Instructor” on the blank line. Change the font to Arial – Bold – Size 2. 
3. Select the text “E‐mail Instructor.”
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4. From the menu at the top select Insert > EMail Link. 

Figure 36: Insert E‐Mail Link 

5. In the dialog box type your email address, as shown in Figure 37. 

Figure 37: Type E‐Mail Address 

6. When you highlight your email link your email address should appear in the Link bar (Ex: 
jclark@austincc.edu). 

Testing Our Links 

Open the home page in the browser and test the links we made. When you click on a link to one of the 
pages we have not yet created, a message saying that page cannot open will display. We will create 
those pages in the next section of our workshop.

mailto:jclark@austincc.edu
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Creating the Other Pages for Our Website 

When we made the links for the left navigation bar we included links to five pages we have not 
created. The first thing we will do in this part of the workshop is to create those five pages. The titles 
of the pages we will create and their file names are: 

1. My Classes – myclasses.htm 
2. Course Resources – courseresources.htm 
3. Meet Instructor – meetinstructor.htm 
4. Contact Instructor – contactinstructor.htm 
5. My Interests – myinterests.htm 

To create the My Classes page, follow these steps: 

1. Select File > Save As on the menu at the top and save the home page as mycourses.htm. 
2. When the new page displays, select Modify > Page Properties and change the page title to My 

Courses. The My Courses page has the same background as the home page and same 
hyperlinks. 

Figure 38: Creating My Classes Page 

3. Click in the main text area. Type “My Classes” as a heading for this page. Select this text and 
change its properties to: Arial > Bold > Size 4. If you wish, change the color of the text to one 
that complements the background and is easy to read. 

4. The text you just typed is centered in the middle of the page. To move it to the top, select it 
again and in the Properties Inspector set the vertical alignment to Top. 

5. Use the techniques we used in Steps 1‐4 to create the other pages: Course Resources, Meet 
Instructor, Contact Instructor, and My Interests. 

6. At the top of the main text area of each new page, type the title of the page. (Hint: use the 
page titles in Step 5). 

7. Save the new pages and test the links on them.
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Spell Check Each Page 

To spell check a web page, press Ctrl + Enter to move to the top of the page and press Shift + F7. The 
spell checker functions the same as the spell checker in Microsoft Word does. 

Insert a Special Character on the Home Page 

To insert the copyright symbol on the home page, follow these instructions: 

1. Press the Enter key once or twice to leave at least one blank line between “E‐Mail Instructor” 
and “Top of Page” on the home page. 

2. Type “Last Updated” and press the spacebar. To insert today’s date, select Insert > Date and 
choose the date format you wish to use. 

3. Press Shift + Enter to advance to the next line without making a new paragraph. 

4. Type “Copyrighted” and press the spacebar. On the menu choose Insert > Special Character > 
Copyright. Press the spacebar and type “by + Your Name.” 

Figure 39: Insert Special Character
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Figure 40 shows the way the home page should look at this point. It will be finished when we add an 
image. 

Figure 40: Home Page for Jimmy Clark’s Website
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Adding an Image to Our Home Page 

We will enhance our homepage by adding an image to it. If you brought an image(s) stored on a disk 
you may insert it or them. Otherwise, we will insert one of the images I installed on your computer. 
The skills/topics covered in this part of the workshop are: 

1. Image formats for web pages 
2. Inserting an image in the home page 
3. Adding alternative text to the image 
4. Changing some of the properties of the image 

Introducing Image Formats for Web Pages 

The three common image formats for web pages are GIF, JPG (JPEG), and PNG. GIF images can display 
a maximum of only 256 colors, but GIF is a lossless format. When the image is resized it does not lose 
any of its resolution. Also, this format supports animation, transparency, and interlacing. Interlacing 
means that when an image is displayed in the browser; at first, a low resolution, out‐of‐focus image is 
displayed. The image gradually comes into focus, until it is displayed at its final resolution. JPG, or 
JPEG, images can display 16.7 millions colors, and are the most common format for photos displayed 
on the Web. JPG is a lossy format; when images are compressed they lose some of their resolution. The 
PNG (Portable Network Graphics) format has all the advantages of the GIF and JPG formats, but it is 
not widely supported by older web browsers. 

Follow these steps to insert an image in the home page: 

1. If you have not already done so, create a folder named Images inside the site folder of your 
website and place the image(s) you will insert in your web pages inside it. 

2. Place the insertion point anywhere inside the third column of the home page and select Insert 
on the menu. The Select Image Source dialog box appears. A preview of the image is displayed 
in the dialog box. 

3. Select the filename of the image you are going to insert and click OK. 

Figure 41: Inserting an Image
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Adding Alternative Text to the Image 

Alternative text is a short message that displays while the image is downloading, and when the 
user moves the mouse over it. To add alternative text to the image you inserted in the home page, 
complete these steps: 

1. Select the image. 
2. Type the message in the Alt box in the Property Inspector. 
3. Save the home page and test it in the browser. Does the alt text you typed appear when 

you move the mouse over the image? 

Figure 42: Adding Alternative Text to the Image 

Changing the Image’s Properties 

Dreamweaver makes it easy to change the properties of an image, such as its size and alignment, To 
change some of the image’s properties, follow these procedures: 

1. Select the image. 
2. To change the size of the image, highlight its width or height (not both) in the Property 

Inspector and type the new value. Press Enter to confirm the change. 
3. To change the alignment of the picture, click one of the alignment buttons in the Property 

Inspector. They look exactly like the ones in Word. 
4. We need to make one more change. You will notice the slash (/) in front of the word “Image” 

in the Src text box in the Property Inspector. If we leave the slash there the picture will not 
download when the web page is uploaded to the server. Press the cursor inside the Src box and 
press Home to move to the slash mark and press the Delete key. 

Figure 43: Changing the Image’s Properties 

5. If time permits today, you may add images to the other pages if you wish. If you do not want to 
add images to any of the other pages of the site, merge the column the body text will be typed 
in and the column that would have held the image. You may add the text to the other pages 
later if we do not have time to do it today.
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Figure 44 shows the completed home page for the site we created in this workshop. 

Figure 44: Completed Home Page 

Printing a Web Page 

To print the HTML code for the home page, select View > Code on the menu at the top of the 
workspace. Select File > Print Code. 

Figure 45: Printing the Home Page’s Code
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To print a web page from a browser, open the page in the browser. Select File > Print from the 
browser menu. 

Figure 46: Printing a Web Page from the Browser 

Uploading Your Website to the Web Server using Dreamweaver FTP 

You cannot upload your website to the ACC web server unless you have an ACC web account. If you do 
not have an ACC web account, go to this website: 
http://www.austincc.edu/helpdesk/forms/web_req.html and request one, but please do not do it 
now. If you decide to use WS_FTP to upload your site, you may find instructions at this site: 
http://insideirt.austincc.edu/webservices/tutorials/StaffWSFTP.pdf . To upload your website to the 
server from inside Dreamweaver, follow these steps: 

1. Click the Refresh button on the Site Panel. 
2. Click the site root folder and then click the Put Files button on the Site Panel. 

Figure 47: Put Files (Uploading the Site)

http://www.austincc.edu/helpdesk/forms/web_req.html
http://insideirt.austincc.edu/webservices/tutorials/StaffWSFTP.pdf
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3. A message box will display asking you if you want to put the entire site. Click OK. 
4. Open the browser and view your site on the Web. Verify your links. 

Other Website Operations 

In the last part of this workshop we will cover opening another site for editing, closing our web pages, 
and quitting Dreamweaver. 

Opening another Site for Editing 

To open another site for editing: 
1. Select Site > Edit Site on the Site Panel. A list of all the Dreamweaver websites on your 

computer displays. 
2. Select the site you wish to edit and click Done. 
3. All the files and folders in this site appear in the Site Panel. 

Closing our Web Pages 

To close the current web page, select File > Close on the menu. To exit Dreamweaver, select File > 
Exit on the menu, or click the red X at the top of the workspace window.


