Twelve Steps to Developing and Maintaining Web Pages in Macromedia Dreamweaver MX
Presented by Jimmy D. Clark
Instructional Development Specialist,
Instructional Development Services
Austin Community College
December 10, 2004

Introduction

Dreamweaver MX is a very popular and powerful Web page design program used by many professional Web designers and millions of amateurs. The purpose of this workshop is to introduce you to some of its basic features. The focus will be on how to open and edit a Web site, and on the creation of very basic Web pages.

First, we will open a Web site and make some editing changes. Then, we will insert a new table in the home page, create two new pages and add pictures to them, add some text hyperlinks, check the spelling in a Web page, print a Web page, and exit Dreamweaver.
Step 1 - The Dreamweaver MX Workspace

Figure 1 shows the Dreamweaver workspace. The Dreamweaver workspace consists of the windows, toolbars, and panel groups that are open when Dreamweaver MX is running.

Figure 1: Dreamweaver MX Workspace
Step 2: Opening a Site for Editing

1. **Figure 2** shows the Site panel. The site that is currently active is named **SAMPLER**. The names of the files and folders included in this site are displayed in the Site panel. The name of the site is displayed in the **Site Name** box. If the Site panel is not displayed, click Window in the menu at the top of your screen, and then select Site.

**Figure 2: The Site Panel**

![Site Panel Image]
2. Clicking the arrow next to the **Site Name** box displays a list of all the Web sites that have been created and accessed recently. If a site is not listed, you can open it by selecting **Site > New Site**. This process is covered in the next set of instructions, **Step 3**. In this tutorial we are going to open and edit a site named **SCUBA**. To open this site, click the arrow, highlight the **SCUBA** site, and click the left mouse button. The files and folders that comprise the SCUBA Web site now display in the Site Pane. This step is illustrated in Figure 3 below.

**Figure 3: Selecting a Site to Open**
3. To open the home page for editing, double-click its file name (*index.htm*) in the Site panel. The home page now displays in the **Document window** and is ready for editing, as illustrated in **Figure 4**.

**Figure 4: Home Page Open in Document Window**
Step 3: An Alternative Way to Open a Site for Editing

1. This time we will use a different method to open the SCUBA Web site. If the Site panel is not displayed in the Dreamweaver workspace, click Window on the menu bar, highlight “Site,” and click the left mouse button. The Site panel now displays on the right side of the Dreamweaver workspace. Your screen should match Figure 5.

Figure 5: The Site Panel
2. To locate the site we are going to open, click the arrow next to “Site” on the site panel, highlight “Edit,” and click the left mouse button to open the Edit Site dialog box. Highlight the name of the site you wish to open and click “Done.” This step is illustrated in Figure 6.

![Figure 6: Edit Site Dialog Box](image)

3. The SCUBA website is now opened in the Site panel, as shown in Figure 7.

![Figure 7: SCUBA Web Site Open in Site Panel](image)
4. To open a Web page for editing double-click the name of the page in the Site panel. Figure 8 shows the home page (index.htm) open in the document window and ready for editing.

Figure 8: The Home Page Open and Ready for Editing
Step 4: Examining the Layout of the Home Page of the SCUBA Web Site

1. The best way to layout out a Web site is to use tables to organize the content. **Figure 9** shows the home page open in **Table Layout** view. To open a Web page in Table Layout view, select **View > Table View > Layout View** on the menu at the top of your screen. The green line marks the border of the table. The blue borders indicate that the table has two columns and five rows.

**Figure 9: Home Page in Table Layout View**

![Home Page in Table Layout View](image)
2. To view the properties of the table we must switch to **Standard** view. Select **View > Table View > Standard View** on the menu at the top of the screen. The **Properties Inspector** should display at the bottom of the workspace. If it is not displayed, select **Window > Properties** from the menu. The Properties Inspector indicates that our table consists of two columns and five rows, and that its width is 95% of the screen area. If this information does not display, right-click inside the table and select **Table > Select Table**. **Figure 10** shows the properties of the table that serves as a container for the information on the home page of our site.

**Figure 10: Properties of Table Displayed in Property Inspector**
3. Let’s examine the elements that make up the home page of the SCUBA Web site. First, the home page banner, “Hank and Barb’s Scuba Diving Site,” spans most of the top row of the table. This banner is a gif image. Click the plus sign (+) to the left of the images folder in the Site panel. The file names for all the images in the Web site now display. Scroll down the list until you see the file named “hank_logo.gif.” This is the image displayed as the home page banner. Select the image on the Web page. The Property Inspector displays the width of the image, 454 pixels, and its height, 43 pixels. Figure 11 shows the properties of the home page banner.

Figure 11: Properties of the Home Page Banner
4. The second row of the table contains three navigation buttons, which make up a navigation bar. Click the button labeled “Home” to select it. The properties of this button, which is an image, display in the Properties Inspector. The name of the image, `divebar_r1_c1`, displays in a label box on the left side of the Inspector. The Source box tells us that the image is located in the **images folder** of the Web site. The image is linked to the `index.htm` file, the file name of the home page. The alt box displays text that will display over the image when the page is opened in the browser. To view the alternative text, click the **F12** function key to open the page in the Web browser. When you move the mouse over the button, the text “**Link to home page**” should display. Close the browser and return to Dreamweaver. Select the other two navigation buttons to see their properties. **Figure 12** shows the properties of the home page button.

**Figure 12: Home Page Button Properties**
Step 5: Inserting a New Table in the Home Page of the Scuba Web Site

1. Save the home page as “indexmod.htm.”

2. Place the insertion point at the end of the line of text that reads “Let’s go diving! –Hank and Barb,” and press the Enter key to insert a blank line.

3. If the Tables tab on the Insert bar is not active, click it to display the Tables button.

4. Click the Tables button. The Insert Tables dialog box should display, as shown in Figure 13. Enter the properties shown in the dialog box.

Figure 13: Insert Tables Dialog Box
5. **Figure 14** shows the new table you just inserted on the home page. Press the **F12** function key to view the modified home page in the browser.

**Figure 14: New Table Inserted on Home Page**

![New Table Inserted on Home Page](image)
Step 6: Formatting the New Table and Adding Text

1. Let’s center the table we inserted in Step 5. To center the table, place the insertion point inside the table (it doesn’t matter where) and select Modify > Table > Select Table from the menu at the top of the screen. Click the arrow to the right of the Align button and change the alignment from Left to Center.

2. Let’s merge the two columns in the first row of the table so we can use this row to label the contents of the table. Place the insertion point on the left border of the top row of the table so that it becomes a black arrow (→). The top row of the table should be highlighted. Right-click and select Table > Merge Cells on the sub menu that displays. The top row of the table now contains only one column.

3. Click anywhere inside the top row of the table and click the Align Center button in the Properties Inspector. Type the label “Prices” in the top row. The word “Prices” is automatically formatted in the default font Dreamweaver uses, Times New Roman. To change the font to match the text on the rest of the page, highlight the text and click the arrow to the right of the box in the Properties Inspector that reads “Default Font.” Select Verdana, Arial, Helvetica on the list of fonts. To bold the text, click the Bold button in the Properties Inspector. If you wish to change the font size of the highlighted word, click the Size button in the Properties Inspector and select another size.

4. Figure 15 shows the rest of the information we will enter in our table. After typing the rest of the text, highlight it and change the font to Verdana, Arial, Helvetica.

Figure 15: The Completed Table

<table>
<thead>
<tr>
<th></th>
<th>Prices</th>
</tr>
</thead>
<tbody>
<tr>
<td>One Hour Dive</td>
<td>$125.00</td>
</tr>
<tr>
<td>Two Hour Dive</td>
<td>$225.00</td>
</tr>
</tbody>
</table>
Step 7: Creating New Web Pages

1. Create new Web page – To create a new Web page, select File > New to display the New Document dialog box, as shown in Figure 16. Under Category, select Basic Page, if it is not pre-selected. Under Basic Page, select HTML, if it is not already selected.

Figure 16: New Document Dialog Box
2. Click the **Create** button to display a new blank Web page in a Document window. **Figure 17** shows the new blank Web page.

**Figure 17: New Web Page Displayed in Document Window**
3. To save the new Web page, select **File > Save** to display the **Save As** dialog box. Make certain that you save the new page in the **SCUBA** website folder. Replace the text in the file name box with **dive_classes.htm**. Be sure you type the underscore to ensure that the page will display in all Web browsers and under all operating systems. **Figure 18** displays the **Save As** dialog box.

**Figure 18: Save As Dialog Box**
4. To create another new page, select File > New. Save the new Web page as products_services.htm. This new page is shown in Figure 19.

Figure 19: Products and Services Web Page

5. Change the page titles – Double-click dive_classes.htm in the Site Panel to display the Web page in the Document window. Select Modify > Page Properties to display the Page Properties dialog box. In the Title box, replace “Untitled” with “Dive Classes.” Select OK. The Page Properties dialog box is displayed in Figure 20. Select Window > products_services.htm to display that page in the Document window. On the Document toolbar, replace the text “Untitled Document” in the Title box with “Products and Services.” Figure 21 shows the file products_services.htm displayed in the Window menu and the Document Toolbar for this Web page. You can use this dialogue box to change all the properties of a page, such as background and link colors.
Figure 20: Page Properties Dialog Box

![Page Properties Dialog Box](image)
Figure 21: Products and Services Window and Document Toolbar for products_services.htm Page
6. **Add table to Dive Classes page** – Double-click the `dive_classes.htm` file name in the Site Panel to open the page in the **Document** window. On the **Insert** bar, select the **Layout** tab and then select the **Standard View** button, if it is not already displayed. Click the **Insert Table** button on the **Insert** bar. In the dialog box, specify the settings shown in Figure 22.

**Figure 22: Insert Table Dialog Box**

![Insert Table Dialog Box](image)

7. Merge the cells in row 1 and add the content shown in Figure 23 to the table. For the banner, use a font style and size you like. Save `dive_classes.htm`. To change the color of the banner text, select **Text > Color** on the menu at the top.

**Figure 23: Completed Dive Classes Table**

![Completed Dive Classes Table](image)
8. Open the **Products and Services** Web page ([products_services.htm](#)) and insert a table with the properties shown in **Figure 24**.

**Figure 24: Properties of Products and Services Table**

![Insert Table](#)

9. Enter the content shown in **Figure 25** in the table you just inserted. Be sure you merge the cells in the top row of the table. For the banner use a font style, size, and color you choose. To make the bulleted list, display the **Text** tab on the **Insert** bar and click the **unordered list**, or **ul** button. Press the **Enter** key after typing each item in the list.

**Figure 25: Entering Text in Products and Services Table**

![Entering Text in Table](#)
**Step 8: Adding Pictures to the New Web Pages**

1. In this step we will add a picture to each of our new Web pages. Open the **Dive Classes** (**dive_classes.htm**) page. First, we must create a blank row in our table to hold the picture. Click anywhere inside the second row of the table. Select **Modify > Table > Insert Rows or Columns** from the menu. Make sure that **Insert Rows, 1 Row, and Above the Selection** are selected in the Insert Rows or Columns dialog box, as shown in **Figure 26**. Click OK to insert a new row below the banner in row 1.

**Figure 26: Insert Rows or Columns Dialog Box**

2. Merge the cells in the row you just inserted. In the **Site panel** click the plus sign to the left of the images folder to display all the images in this folder. Highlight the first image, **a_reef.jpg**, keep the left mouse button depressed, and drag the image into the second row of the table. When the small icon of the image (a white sheet of paper) is inside the second row of the table, release the mouse button. The image of the reef should now display in the second row. Click outside the image and right-align it, using the right alignment button in the **Properties Inspector**. Does your table now look like the one in **Figure 27**? Save the Web page.
### Schedule of Scuba Diving Classes

<table>
<thead>
<tr>
<th>Course</th>
<th>Dates</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beginning Scuba Diving</td>
<td>Mar 1 - Mar 31</td>
</tr>
<tr>
<td>Intermediate Scuba Diving</td>
<td>Apr 1 - Apr 30</td>
</tr>
</tbody>
</table>
3. Open the **Products and Services** ([products_services.htm](#)) page and insert the `a_wreck.jpg` image in the **left column** in the **second row** of the table. Center this image in the cell. This step is illustrated in **Figure 28**.

**Figure 28: Wreck Image Inserted in Products and Services Table**
Step 9: Adding Text Hyperlinks to the Web Pages

1. In this step we will add text hyperlinks to the two pages we created and we will place hyperlinks to the new pages on the home page. Open the *dive-classes.htm* page in the Document window. Add a new row below the row containing the text “Intermediate Scuba Diving.” The quickest way to add the new row is to click to the right of the text “Apr 1 – Apr 30” and press the Tab key. Merge the cells in the new row.

2. Type the names of the following pages in the new row, separating each page name with a vertical bar (|). (To type the vertical bar character, hold down the Shift key and type the character below the Backspace key: Home, Dive Locations, Photo Gallery, Dive Classes, Products and Services. Center the text in this row, bold it, and change the font to Verdana, Arial, Helvetica. Check your work with Figure 29.

Figure 29: Text Navigation Bar for Dive Classes Page
3. Now, we will make hyperlinks to the Web pages listed in the navigation bar we just typed in the bottom row of our table. Highlight the word “Home.” Click the Browse for File icon to the right of the Link text box. The Select File dialog box should open. Highlight the “indexmod” filename and click OK. The word “Home” is now blue, underlined text, indicating that you have made a hyperlink to the home page, the indexmod.htm file. (Note: Delete the forward slash (/) that appears to the left of the name of the link in the link bar).

4. Link the Dive Locations page to the locations.htm file, Photo Gallery to the photos.htm file, Dive Classes to dive_classes.htm, and Products and Services to products_services.htm. Press F12 to open the Web page in the browser and click each link to verify that it works correctly. Figure 30 shows the completed navigation bar.

**Figure 30: Navigation Bar for Dive Classes Web Page**
5. Select all the text in the row that has the navigation bar on it. Select **Edit > Copy** on the menu at the top of the page. Open the **Products and Services** page and merge the cells in the bottom row. Place the insertion point in the bottom row of the table and select **Edit > Paste** to paste the navigation bar into the table. Open this page in the browser and test the links.

6. To test what you have learned in this section, open the **indexmod.htm** file and add links to the Dive Classes and Products and Services pages on the link bar at the bottom of the Web page. Test these links in the browser. **Figure 31** shows the completed link bar for the home page.

**Figure 31: Completed Link Bar for Home Page**
Step 10: Checking the Spelling in a Web Page

1. To check the spelling in a Web page, press Ctrl + Home to move the insertion point to the first line of text. Select Text > Check Spelling on the menu. When the spell checker finds a misspelled word a dialog box similar to the one in Figure 32 is displayed.

   Figure 32: Spell Checker Dialog Box

2. Usually, a list of suggested corrections displays. If the correct spelling is on the list, highlight it and click the Change or Change All button. If the word is spelled correctly, click the Ignore or Ignore All button. When the spell checker has checked the entire document, the message “Spelling check completed” displays. Click OK to remove the dialog box.
Step 11: Printing a Web Page

1. You cannot print a Web page from Dreamweaver. Open the page in the browser and select **File > Print**. It is a good idea to preview the document by selecting **File > Print Preview** before printing a Web page because you may be about to print more pages than you realize.

2. You can highlight and copy the parts of a Web page you wish to print, open **Word**, and paste the section of the page into it before printing.

3. If you would like to print the background and the images on a Web page, open the page in the browser. Select **Tools > Internet Options > Advanced** from the menu below the title bar, scroll down the list until you find “Printing,” and check the box beside “Print background colors and images.” Figure 33 shows this dialog box.

Figure 33: Internet Options Dialog Box
Step 12: Closing a Web Page and Quitting Dreamweaver

1. Always save a Web page before closing it. The program will prompt you to do this. To close a Web page, select File > Close, or click the Close button (X) in the Document window.

2. To quit Dreamweaver, select File Exit on the menu, or click the Close button (X) in the upper-right corner of the Dreamweaver window.